Firefox 11.0 issues?

  1. 7 years ago

    I just upgraded to the new firefox 11.0 and it seems when logging on to the panel it just stays there forever not showing me the page just keeps loading. Anyone else have this issue?

    Currently using FOP2 2.25

  2. admin

    21 Mar 2012 Administrator

    Firefox 11 supports websockets, and sends the handshake in a funny way. I will update fop2 to fix this, in the meantime you can disable websockets in fop2 itself or in firefox.

    For fop2, (since version 2.24), edit /var/www/html/fop2/js/presence.js and set

    disableWebsockets=true

    In Firefox

    about:config

    and set

    network.websocket.enabled = false

    Best regards,

  3. We have disabled websockets in FOP2. This did not resolve the login issue. We even tried restarting FOP2. Did not work.

    We did resolve the issue by disabling websockets in Firefox but would prefer not to do this since it will change the way Firefox engages with other applications and websites.

    Any suggestions?

    Do you have an ETA on when this will be resolved?

    Thanks for your insight!

  4. Hello.

    What if you have version 2.20?
    Here it's not possible to set the disableWebsockets=true in the /var/www/html/fop2/js/presence.js

    Best regards

    /JB

  5. admin

    21 Mar 2012 Administrator

    We have disabled websockets in FOP2. This did not resolve the login issue. We even tried restarting FOP2. Did not work.

    We did resolve the issue by disabling websockets in Firefox but would prefer not to do this since it will change the way Firefox engages with other applications and websites.

    Any suggestions?

    Do you have an ETA on when this will be resolved?

    Thanks for your insight!

    disablewebsockets in fop2.cfg WORKS FINE. The problem is that the presence.js file is CACHED in your browser, you can force refresh that file

    http://your.server/fop2/js/presence.js

    read it, is disableWebsockets disabled? yes? no? If the file is cached (old contents), shift-RELOAD the page until you see it changed. Then go back to the /fop2 regular page, and shift-RELOAD there.

    Anyways, fop2 version 2.26 was just released. Works with firefox 11.

    Best regards,

  6. admin

    21 Mar 2012 Administrator

    Hello.

    What if you have version 2.20?
    Here it's not possible to set the disableWebsockets=true in the /var/www/html/fop2/js/presence.js

    Best regards

    /JB

    If you have FOP 2.20 you will have to upgrade FOP2 or disable websockets in firefox:

    about:config

    network.websocket.enabled=false

    Best regards,

  7. 6 years ago

    I also have this problem with FOP2 2.26, and solved it by disabling websockets in firefox, but I am not able to fix by modifying presence.js.

    I have inserted this line into /var/www/html/fop2/js/presence.js:

    var disableWebSockets = true;

    But this will not resolve the issue. I also tried adding the same line to /usr/local/fop2/fop2.cfg, and again did not solve the issue. Is there a syntax error? Do I need to reboot the server? I have also tried clearing cache in firefox, and 'force updating' presence.js by navigating directly to it in the browser. More info?

    John

  8. admin

    19 May 2013 Administrator

    The presence change will solve the issue, but only when the presence.js file is reloaded in the browser. You will have to clear/flush your browser cache to force a reload of the file.

  9. 3 years ago

    disableWebSocket = true doesn't seem to be working for me either.
    I notice that in some place on this forum it's written "disableWebsockets", sometimes "disableWebSockets", and in my presence.js file and on the installation manual site "disabeWebSocket".
    Can you please confirm what is correct?
    Thank you

  10. admin

    23 Jul 2015 Administrator

    The correct value is disableWebSocket , the same that is written by default in the stock presence.js file. You do not need to add it, if you have to add it is beause you have a presence.js file from a previous version than 2.26. Previous versions won't work, you must use at least 2.26. And since 2.27 you do not need to disable websockets, as it works with all major browsers because FOP2 supports secure web sockets since 2.27 (the only thing that could prevent websockets from working currently).

    Best regards,

  11. Then perhaps im going at this the wrong way.
    I have an autodirect from http to https. In IE, the fop2 is extreamly slow to connect and when it finally does, it doesnt show correct values (it shows all extensions as connected and then just freezes like that).
    If i disable the ssl autodirect it works fine.
    In chrome it works fine also with ssl.
    If it has nothing to do with websockets, any ideas?

  12. admin

    25 Jul 2015 Administrator

    If you have a modern web browser, (chrome or firefox on latest releases), then do not disable websockets, let them be enabled, and be sure to configure the ssl certificates in fop2.cfg so secure websockets can be negotiated on first attempt.

or Sign Up to reply!