Globally disable 'click here to enable desktop' and actions

  1. 6 years ago

    We are integrating FOP2 support into yaai (yet another asterisk integration) it's sugarcrm's premier telephony integration.
    https://www.github.com/blak3r/yaai/wiki

    A) I'd like to be able to disable the growl style "click here to enable desktop notifications" globally. So, every user doesn't see this.

    B) It'e be nice if you could globally turn off some of the buttons across the top such as the dial bar, filter bar, extension dial etc which aren't really needed in our application.

    We've come up with workarounds and they are outlined here:
    https://github.com/blak3r/yaai/issues/110

    But, it'd be nice if we didn't have to tell users to modify core files in order to make it work.

  2. admin

    1 Feb 2013 Administrator

    Hi,

    You can remove action buttons via fop2 user permissions. If you use "all", it will display all action buttons. If you use instead something like "dial,transfer,pickup,hangupself", you will see just the buttons I see on the screenshot on that bug report.

    The click here to allow desktop notifications is only google chrome specific, and is a frequently requested feature (to have notifications outside the browser). Chrome will request user permission before enabling them because nobody wants spam notifications on their desktops. Anyways, once you allow it, it will not prompt you anymore. Perhaps I can add an option to disable desktop notifications altogheter...

    Best regards,

  3. yeah, it'd be nice if there was a way to disable the desktop notification thing. It's unlikely users who buy FOP2 as an extension to our CRM integration will want to use it.

    Also, is there any documentation on what users need to do with a stock FreePBX (in my case PIAF Purple) to exclude the FOP2 folder from first requiring the user to login to FreePBX? On my box I need to first login to FreePBX before I can send the FOP2 url string with basic auth params embedded.

  4. admin

    28 Feb 2013 Administrator

    Hi,

    If you are required of any kind of login to access the /fop2 folder is because of your apache configuration. Just change it, most probably you have some kind of .htaccess file or rules in httpd.conf to ask for a password for the whole /html folder.

    This has nothing to do with fop2 itself, nor freepbx. What you are prompted is not a freepbx login either. Just a regular apache restriction (look at apache config files, not freepbx nor fop2 config files).

    Best regards,

  5. 5 years ago

    Yeah, you were right. I have faced the very same issue and it was just because of the lines in the .htaccess file. I forgot about password protection of a folder in the folder. Nothing wrong with the fop2 though.

  6. admin

    29 Nov 2013 Administrator

    In fop 2.27 desktop notifications can be disabled via presence.js:

    var desktopNotify      = false;

or Sign Up to reply!