Chrome extension cant access server

  1. 5 years ago

    Hi
    I have the FOP2 Lite edition working as a trial and can login and access it using Chrome on my PC. This is working perfectly and pops open the caller id information etc.

    I have now added the Chrome extension to get the Click to Dial option working, however using the same credentials as I use for the FOP2 desktop the extension just says that it is unable to connect. The only parameters I have included are:

    • the FOP2 Server
    • Port I have left at the default
    • Extension - same as I use to login to FOP2
    • Password same as I use to login to FOP2
    • Context - left bank

    Any ideas on what the issue might be or how to troubleshoot the connection issue?

  2. admin

    7 Dec 2013 Administrator

    Be sure you have websockets enabled in /var/www/html/fop2/js/presence.js. The chrome extension requires websockets to be enabled.

    disableWebSocket=false;

  3. I got the same problem. Chrome extension connects, but no pop ups. Checked presence.js, fop2.cfg, iptables, Chrome popup blocking settings (to off) - all seems good. Fop2 recently updated from 2.26 to 2.27.

  4. admin

    23 Dec 2013 Administrator

    I got the same problem. Chrome extension connects, but no pop ups. Checked presence.js, fop2.cfg, iptables, Chrome popup blocking settings (to off) - all seems good. Fop2 recently updated from 2.26 to 2.27.

    If it connects, then it is not the same problem. Did you configure any url in the chrome extension options? You won't get any popups if you do not define an url there.

  5. Yes, chrome plugin is configured with popup url. Strange, but after recreating extension it started working but for short time. I don't know exactly when, but guess that after asterisk reload it stopped again. Even tried to reboot, but nothing.
    Seems it's not only chrome - FOP2 panel also shows no notification or configured popup.

  6. admin

    26 Dec 2013 Administrator

    If its for an asterisk reload it would be easy to reproduce. If we cannot reproduce a problem, then it will be hard to fix or even to acknowledge it as a bug/problem in the software and not a matter of misconfiguration. So, you can restart fop2:

    service fop2 restart

    If you say it worked after recreating an extension, restarting the service should be enough to get it in "fresh/working" state. So, you should get popups after a restart.

    Assuming that an asterisk reloads breaks further popups, then just issue a reload:

    asterisk -rx "module reload"

    Then try again, did you lose the popups?

    Best regards,

  7. Hi
    I have the FOP2 Lite edition working as a trial and can login and access it using Chrome on my PC. This is working perfectly and pops open the caller id information etc.

    I have now added the Chrome extension to get the Click to Dial option working, however using the same credentials as I use for the FOP2 desktop the extension just says that it is unable to connect. The only parameters I have included are:

    • the FOP2 Server
    • Port I have left at the default
    • Extension - same as I use to login to FOP2
    • Password same as I use to login to FOP2
    • Context - left bank

    Any ideas on what the issue might be or how to troubleshoot the connection issue?

    I found this thread when experiencing the same problem. (The thread is highjacked , and the original question was not resolved).

    I was able to resolve this problem by trial and error. I thought I would post up what I found, as it was not obvious (to me), and not documented.

    Solution:
    In the "Fop2 Server" dialog box, enter the address of the server as a dns name, not as an IP address, and it works.

    If the IP address is entered, it indicates: invalid credentials.
    changing it to a dnsname, such as: abc.yourdomain.local with no other changes - works immediately.

    WFM. Hope this helps others. :)

  8. admin

    31 Jan 2014 Administrator

    Solution:
    In the "Fop2 Server" dialog box, enter the address of the server as a dns name, not as an IP address, and it works.

    If the IP address is entered, it indicates: invalid credentials.
    changing it to a dnsname, such as: abc.yourdomain.local with no other changes - works immediately.

    WFM. Hope this helps others. :)

    Thanks for the feedback. For whomever has issues connecting, it is worth a try.

    Howeve let me tell you that I can use ip addresses or hostnames and it works fine either way for me.

    Best regards,

  9. Ok, just to test, I changed it back to the IP address, and... it continued to work.
    so, I don't know what it was !?!

    All I can say for sure is: when I used the IP address, it refused to accept the credentials. When I used DNS name, it worked - no other changes. Now, it seems to be happy either way.

  10. admin

    3 Feb 2014 Administrator

    Either the hostname was not written correctly (a typo maybe?) or there were other factors not related to the config (fop2 server not running, network problem, etc).

or Sign Up to reply!