"FOP2 Server is not responding. Be sure the service is running!" - Remote Installation

  1. 2 years ago

    I am re-tackling attempting to get FOP2 to work from a remote server and everything reports correctly on the CLI, but FOP2/admin says "FOP2 Server is not responding. Be sure the service is running!"

    [root@fop2 ~]# mysql -u fop2 -pfop222 -h pbx.domain.com asterisk -e "SHOW VARIABLES LIKE '%version%';"
    +-------------------------+---------------------+
    | Variable_name           | Value               |
    +-------------------------+---------------------+
    | protocol_version        | 10                  |
    | version                 | 5.1.73              |
    | version_comment         | Source distribution |
    | version_compile_machine | x86_64              |
    | version_compile_os      | redhat-linux-gnu    |
    +-------------------------+---------------------+
    [root@fop2 ~]# /usr/local/fop2/fop2_server --test
    Flash Operator Panel 2 - Valid License (/usr/local/fop2/fop2.lic)
    Flash Operator Panel 2 - Featureset: Basic
    Flash Operator Panel 2 - Allowed Tenants: 5
    Flash Operator Panel 2 - Licensed Plugin: queuestats
    Flash Operator Panel 2 - Licensed Plugin: idletimer
    Connection to manager OK!
    [root@fop2 ~]# telnet pbx.domain.com 5038
    Trying ...
    Connected to.
    Escape character is '^]'.
    Asterisk Call Manager/1.1
    Action: login
    Username: fop2
    Secret: fop222
    Events: off
    
    Response: Success
    Message: Authentication accepted
    
    ^]
    telnet> quit
    Connection closed.
    [root@fop2 ~]#
    /var/www/html/fop2/admin/config.php
    $DBHOST="IPOFPBXSYSTEM";
    $DBUSER="fop2";
    $DBPASS="fop222";
    $DBNAME="asterisk";
    $ENGINE='freepbx';
    [general]
    ; AMI definitions
    manager_host=IPOFPBXSYSTEM
    manager_port=5038
    manager_user=fop2
    manager_secret=fop222
    [root@fop2 ~]# service fop2 status
    fop2_server (pid 1979) is running...
    [root@fop2 ~]# pgrep fop2
    1979

    Any ideas what else to check?

    I also ran the following:

    mysql -u root -p -e "CREATE USER 'fop2'@'%' IDENTIFIED BY 'fop222';"
    mysql -u root -p -e "GRANT ALL PRIVILEGES ON asterisk.* TO 'fop2'@'%';"

    The FOP2 Manager does not connect to the remote asterisk server, it connects to the local running FOP2 daemon over port TCP/4445 on host "localhost". If the hostname "localhost" resolves correctly, and if port TCP/4445 is open and not filtered by firewalls, and you do not have SELINUX preventing web applciations to open socket connections, then the FOP2 manager will be able to test the local socket connection and see if the FOP2 service is working or not.

    So, focus on that (local machine), not on the remote FOP2 - Asterisk interconnection, as it is not relevant for the particular error you are reporting/seeing.

    You might need to disable SELinux or configure it to allow socket connections, you should check if "localhost" resolves, and check that your iptables rules allows connections to tcp/4445 on localhost.

    Best regards,

  2. I'd really like some help with this, I'm going to fire up a Brand new Setup to test w/ instead of testing on a server w/ a bunch of configs from old setups.

  3. admin

    10 Jan 2017 Administrator Answer

    The FOP2 Manager does not connect to the remote asterisk server, it connects to the local running FOP2 daemon over port TCP/4445 on host "localhost". If the hostname "localhost" resolves correctly, and if port TCP/4445 is open and not filtered by firewalls, and you do not have SELINUX preventing web applciations to open socket connections, then the FOP2 manager will be able to test the local socket connection and see if the FOP2 service is working or not.

    So, focus on that (local machine), not on the remote FOP2 - Asterisk interconnection, as it is not relevant for the particular error you are reporting/seeing.

    You might need to disable SELinux or configure it to allow socket connections, you should check if "localhost" resolves, and check that your iptables rules allows connections to tcp/4445 on localhost.

    Best regards,

  4. I followed my notes on a brand new setup @ home w/ SNG7 + CentOS 6/FOP2 and it gave same error, disabled SELINUX and it worked :), thanks! Now on locking it down correctly , AKA IPTables + SELinux, I chose CentOS 6 because you Rec it in the guide, but I prefer CentOS 7.

    Any chance you have a guide/ or the Commands to allow SELinux/IPTABLES/FirewallD for this setup? If not, it will be a good chance for me to learn a bit about SELinux and firewalls anyway, but if you have a writeup, I'd save the time for now :). This makes me very happy, thanks! Hopefully won't be bugging you for a while now, once I get it setup in its own VM, it won't be bothered when I mess with the PBX system. (Which will be a lot in the future, going from FreePBX 2.9/Ast 1.8 CentOS 5 >> SNG7 FreePBX 14/Ast ?? Hopefully is the plan!)

  5. admin

    10 Jan 2017 Administrator

    Hi, this FAQ entry might help:

    http://www.fop2.com/docs/faq.php#WhenItrytodownloadvoicemailorrecordingsIgeta"noway"message ?

or Sign Up to reply!