FOP2 v2.31.22 on Raspberry Pi

  1. last week

    Hi,

    I'm trying to update FOP2 on my Raspberry Pi with Debian 8 (not Raspbian).
    I was running v2.30.3 for Debian RPI and was happy with it but I'm now trying to update to v2.31.22 for Debian RPI.
    I've got this error when trying to start/restart fop2 service:

    Can't load '/tmp/par-726f6f74/cache-2312cfdda51ea9b74a50b9c8c4b9963b50338da6/9798ca90.so' for module Filter::Crypto::Decrypt: libcrypto.so.1.0.2: Ne peut ouvrir le fichier d'objet partagé: Aucun fichier ou dossier de ce type at /usr/lib/arm-linux-gnueabihf/perl/5.24/DynaLoader.pm line 187.
    at /usr/share/perl5/PAR/Heavy.pm line 123.
    BEGIN failed--compilation aborted at /tmp/par-726f6f74/cache-2312cfdda51ea9b74a50b9c8c4b9963b50338da6/inc/lib/Filter/Crypto/Decrypt.pm line 37.
    Compilation failed in require at script/fop2_server.pl line 1.
    BEGIN failed--compilation aborted at script/fop2_server.pl line 1.

    So I searched on this forum and type this code on my box:

    # ls -l /usr/lib/arm-linux-gnueabihf/libcrypt*
    -rw-r--r-- 1 root root   39296 juin  18  2017 /usr/lib/arm-linux-gnueabihf/libcrypt.a
    -rw-r--r-- 1 root root 1123652 mars   1 23:04 /usr/lib/arm-linux-gnueabihf/libcrypto.so.1.0.0
    lrwxrwxrwx 1 root root      38 juin  18  2017 /usr/lib/arm-linux-gnueabihf/libcrypt.so -> /lib/arm-linux-gnueabihf/libcrypt.so.1
    # ln -s /usr/lib/arm-linux-gnueabihf/libcrypto.so.1.0.0 /usr/lib/arm-linux-gnueabihf/libcrypto.so.1.0.2
    # ldconfig

    Now I'm getting a new error when trying to start fop2 service:

    Can't load '/tmp/par-726f6f74/cache-2312cfdda51ea9b74a50b9c8c4b9963b50338da6/9798ca90.so' for module Filter::Crypto::Decrypt: /usr/lib/arm-linux-gnueabihf/libcrypto.so.1.0.2: version `OPENSSL_1.0.2d' not found (required by /tmp/par-726f6f74/cache-2312cfdda51ea9b74a50b9c8c4b9963b50338da6/9798ca90.so) at /usr/lib/arm-linux-gnueabihf/perl/5.24/DynaLoader.pm line 187.
    at /usr/share/perl5/PAR/Heavy.pm line 123.
    BEGIN failed--compilation aborted at /tmp/par-726f6f74/cache-2312cfdda51ea9b74a50b9c8c4b9963b50338da6/inc/lib/Filter/Crypto/Decrypt.pm line 37.
    Compilation failed in require at script/fop2_server.pl line 1.
    BEGIN failed--compilation aborted at script/fop2_server.pl line 1.

    My OpenSSL version is quite old (Debian 8), so I guess this is the problem:

    # openssl version
    OpenSSL 1.0.1t  3 May 2016

    Any idea on how to fix this error?
    Thanks in advance!

or Sign Up to reply!