TheShniz

Member

Last active 4 months ago

  1. 4 months ago
    Thu Jul 26 15:28:50 2018
    TheShniz started the conversation CCSP Realtime Counters.

    I've got a fresh install of Asterisk 11.25.3, FreePBX 2.11, CentOS 6.9, CCSP 2.2.4 & the call counts are not ticking in Realtime Display... I've got a customer complaining and would like to get this squared away; I know it must be simple... please let me know what I should be looking for, thank you!

  2. last year
    Wed Aug 23 18:50:53 2017
    TheShniz posted in Moving CCSP Database.

    Help?

  3. Thu Aug 17 16:02:16 2017
    TheShniz posted in Moving CCSP Database.

    I really do need help...

    How can I go about getting the old data into the new system?

    Do I just import the tables/data that exists; and, will all the fields line up?
    ( v2.0.7's database has only 16x tables, whereas v2.1.3's database has 23x tables )

  4. Wed Aug 9 17:36:53 2017
    TheShniz started the conversation Moving CCSP Database.

    Is it safe, and how can I move the database records from CCSP v2.0.7 to CCSP v2.1.3?

    I have a single site with two (2) systems... 1x old system running CCSP v2.0.7 that has been used for 2x years and is being kept as a cold standby for failover, and 1x new system running CCSP v2.1.3 that is just installed as replacement and being used from now on. In order to avoid licensing issues with failover, each system has it's own activation code.

    ( I tried to submit using support.asternic.biz w/ FF, Chrome, & IE... but the new ticket forms simply stays @ "Loading..." with no submission, and you no longer have the online chat :'( )

  5. Fri Jun 16 18:35:46 2017

    This is a complete chassis upgrade w/ new drives for an existing customer, and when I had done a restore of a previous backup on this new machine... the restore was mistakenly referencing a path for an older release of Asterisk (i.e. /usr/lib64/asterisk/modules - instead of - /usr/lib/asterisk/modules). Once corrected, FOP2 was happy again!

    No more live chat?
    - J

    {SOLVED}

  6. Wed Jun 14 19:12:37 2017
    TheShniz started the conversation error retrieving current directory (2.31.10).

    Tried Firefox, Chrome, & IE on new support ticket system, and the page is having the green submit button saying 'loading...'

    What steps will reproduce the problem?
    service fop2 restart

    What do you expect to happen?
    Shutting down Flash Operator Panel 2: [ OK ]
    Starting Flash Operator Panel 2: [ OK ]

    What happens instead?
    shell-init: error retrieving current directory: getcwd: cannot access parent directories: No such file or directory
    chdir: error retrieving current directory: getcwd: cannot access parent directories: No such file or directory
    Shutting down Flash Operator Panel 2: [ OK ]
    Starting Flash Operator Panel 2: [ OK ]

    What version are you running?
    2.31.10

    What is your activation code?
    s********A (brand new install)

    Hoping you can help, need to ship... thank you!
    - J

  7. 6 years ago
    Thu Nov 8 14:38:45 2012

    Yeah, I opened a rather long support ticket w/ you @ asternic where you can see the steps I took to identify and solve the issue, for search purposes...

    asterisk.fop2buttons was in utf8_general_ci whereas everything else was in utf8_unicode_ci, causing an issue with the (rather long) sql statement in autoconfig-buttons-freepbx.sh w/ comment "#si no tiene device and user, exclusimos los USER/"

    The fix was to update the database w/:

    alter table `asterisk`.`fop2buttons` convert to character set utf8 collate utf8_unicode_ci;

    ...and now the buttons.cfg is being generated correctly and users can now view fop2. I'm not sure why or how fop2buttons got to be put into utf8_general, but this has fixed me up... hopefully this will help you with other installs as well.

    Thanx Nicolas :),
    - J

    FYI: I've automated the install of FOP2, and have used the same identical process on a variety of systems (all CentOS 5 x86 though)... this was the first time I've ever had issues, figured it was yet another CentOS 6.3 x64 thing (as it was my first attempt on the new OS).

  8. Wed Nov 7 20:51:00 2012
    TheShniz started the conversation Help w/ CentOS 6.3 x64, Asterisk 1.8.17, & FPBX 2.9.

    Logging into FOP2 gets me a blank page with only "Filter, Dial, & Presence" at the top...
    I've tried redownloading & reinstalling to no avail, and it did take my license (just purchased)

    Help?
    - J

    This is using:
    fop2-2.26-centos5-x86_64.tgz & fop2admin-1.2.11.tgz
    w/ Visual Phonebook (database looks clean as far as I can tell)
    w/ FOP1 renumbered port to 4444 (works fine)
    on CentOS 6.3 x64 w/ FPBX 2.9.0.12

    Per instructions, tried (sperately):
    ln -s /usr/lib64/libcrypto.so.1.0.0 /usr/lib64/libcrypto.so.6
    ln -s /usr/lib64/libcrypto.so.10 /usr/lib64/libcrypto.so.6

    /usr/local/fop2/fop2_server --test
    Flash Operator Panel 2 - White Label Version.
    Flash Operator Panel 2 - White Label License (3)
    ERROR 1267 (HY000) at line 1: Illegal mix of collations (utf8_general_ci,IMPLICIT) and (utf8_unicode_ci,IMPLICIT) for operation '='
    Connection to manager OK!

    perl --version
    This is perl, v5.10.1 (*) built for x86_64-linux-thread-multi

    netstat -lnp | grep 4445
    tcp 0 0 0.0.0.0:4445 0.0.0.0:* LISTEN 12760/fop2_server

    netstat -lnp | grep 4444
    tcp 0 0 0.0.0.0:4444 0.0.0.0:* LISTEN 12709/perl

    uname -r
    2.6.32-279.el6.x86_64

    asterisk -rx "core show version"
    Asterisk 1.8.17.0 built by root on a x86_64 running Linux on 2012-11-02 20:09:04 UTC