Jeremy

Member

Last active 6 months ago

  1. last year
    Thu Oct 19 21:19:32 2017
    Jeremy started the conversation Longest hold time in queue summary.

    I use FOP at a number of locations and it is very helpful. Thank you very much!

    One feature request I have based on user feedback is for the queue buttons that are collapsed into summary mode to also include the Call Waiting Timer of the first/longest call in queue.

    i.e. Currently the summary shows Agents and Waiting Calls only. The request is to have one more line that has the timer.

    That way it is would be very easy to see the wait times across all your queues in a nice compact screen without having to expand each button into its Detailed view (which can take up a lot of real estate on the screen).

  2. Thu Oct 19 19:03:07 2017

    I find that doing a "fop2 reload" on the server causes everything to refresh on existing browser sessions, so a possible workaround could be to scheduled automated reloads periodically (presumably there is no harm in doing so).

  3. Thu Oct 19 16:47:17 2017

    Looking into this more closely, it turns out that it's not just the call timers that are an issue. The member status listed inside the Queue button (DND, on-call, available) becomes incorrect after awhile too.

    Again, the data in the member's Extension button is correct during this, but the member listing inside the Queue buttons does not update properly after a while. And again, refreshing the browser window gets things back to normal for a while.

    In the following attachment, you can see in the extension buttons that clerk 2 and clerk 3 are actively on a call (which is correct), but one of the queue buttons below incorrectly shows them both as being paused. If I refresh my browser window, then they reflect the correct status in the queue button again... for a while.

  4. Wed Oct 18 19:44:36 2017
    Jeremy started the conversation Call Timers inside Queue Buttons wrong.

    I am seeing that the call timers inside the Queue buttons get out of sync rather quickly (the Extension button's timer & status are correct, but not always the timers listed inside each Queue button).

    You can see in my attached screenshot that Clerk 14 is currently in a call and has been for 8 seconds. The upper Queue button correctly shows clerk 14 is active in a call for 9 seconds (close enough), but the bottom Queue button never stopped counting since his previous call, and now is up to 1:17 and climbing.

    I have turned on debug logging with -X 3 and I do see AgentConnected and AgentComplete messages occur as expected when this happens. If I refresh the page in my browser (Chrome), everything is correct again for a short while, but before long I start seeing some of these mismatched timers again.

    I am using Asterisk 13 (in which eventmemberstatus is deprecated, but the same events are always sent by default ) with FOP 2.31.15 and I have my manager.conf setup with the event filters described in the installation instructions here:
    https://www.fop2.com/docs/installation.php#ConfiguringtheServer

    It just appears as though not all of the AgentComplete messages are always being processed, or are only updating some of the Queue buttons but not others for some reason.

    I tried cranking up the poll_interval to see if that could work around the problem, but it hasn't helped that I've noticed.

    Any thoughts for me? Or any additional information I can provide?

  5. Sat Sep 16 00:03:27 2017

    Just as an update to anyone running across this...
    I did a new install of 2.31.15 at at a nearly identical site (again, without a database), and the manager page is working for me again!
    The one new step is, as you mentioned above, in config.php I need to change ADMINUSER and ADMINPWD to something other than the default "fop2admin". Once that's done, I am able to login to the manager page and all the buttons show up and I can save setting normally, etc.

  6. 2 years ago
    Fri May 26 16:20:18 2017

    I removed the file and restarted, and a new fop2settings.db was created with proper perms, but I still get the same error when trying to edit anything in the administrator page.
    For now it seems the workaround is to do a clean install of 2.31.08, set everything up the way I want it, and then upgrade to 2.31.09.
    I'll also try a clean install of 2.31.09 (without a previous version to upgrade) to see if the problem is actually upgrade-related or just inherent to 2.31.09 when not running a database.

  7. Wed May 24 23:21:30 2017

    Hmmm... perms seems to be fine. The fop2settings.db is 666 and the owning folder is 755. fop2_server is running as root and owns the folder and files.
    SELinux is turned off.
    Where/how would I add the echo lines?

  8. Tue May 23 23:46:48 2017

    We are getting close!
    That worked, and I can see all the buttons now, but whenever I try to make any change and try to submit it, I get the following error:
    DB Connection fail: SQLSTATE[HY000]: General error: 1 SQL logic error or missing database

    I've checked and double-checked the perms of my fop2settings.db file and containing folder, so I don't think taht's the problem (and the error is slightly different for permissions problems anyway: DB Connection fail: SQLSTATE[HY000]: General error: 14 unable to open database file)

    Thank you for your continued support.

  9. Mon May 22 23:42:15 2017

    Specifying a different login in config.php does work, BUT once I'm in, there are no longer any buttons on the left panel for me to configure anything. Mainly I'm just interested in the Settings button, so I can set showLines to 1 and some other display related settings.

  10. Mon May 22 21:04:12 2017

    Thanks for the reply.
    However, I'm actually using FOP2 and Asterisk without a database for simplicity. I realize this limits the availability of many features, but I formerly was able to use the fop2admin page for changing some various options.

View more