FOP2 error after upgrade to FreePBX 2.11

Get help on installation and configuration.

FOP2 error after upgrade to FreePBX 2.11

Postby robya » Mon Jul 01, 2013 5:14 pm

I had a functional FOP2 setup running on FreePBX 2.10. I did the update to 2.11 and the system would not load the Asterisk service. I found a note that said to uninstall FOP2 admin module. http://www.freepbx.org/forum/general-he ... ot-applied - That did not completely fix the issue.

I contacted Schmooze and they found the CEL was an error, we moved the cel_*.so modules out of /usr/lib/asterisk/modules to the home directory. - Now FreePBX seems to work.

Once the server was back up I tried to reinstall the FOP2 Admin module again and the FreePBX server had and error and Asterisk stopped running. I have since uninstalled the service and the server is fine. I have version 2.26 of FOP2


Errors
Reload failed because retrieve_conf encountered an error: 1

exit: 1

[FATAL] Unable to connect to Asterisk Manager from /var/lib/asterisk/bin/retrieve_conf, aborting
1 error(s) occurred, you should view the notification log on the dashboard or main screen to check for more details.

# tail /var/log/asterisk/full
[2013-06-28 16:56:16] VERBOSE[23290] manager.c: == Manager registered action M
[2013-06-28 16:56:16] VERBOSE[23290] manager.c: == Manager registered action A
[2013-06-28 16:56:16] VERBOSE[23290] config.c: == Parsing '/etc/asterisk/manag
[2013-06-28 16:56:16] VERBOSE[23290] config.c: == Parsing '/etc/asterisk/manag d
[2013-06-28 16:56:16] VERBOSE[23290] config.c: == Parsing '/etc/asterisk/manag
[2013-06-28 16:56:16] WARNING[23290] manager.c: Invalid writetimeout value '' at
[2013-06-28 16:56:16] VERBOSE[23290] config.c: == Parsing '/etc/asterisk/cdr.c
[2013-06-28 16:56:16] NOTICE[23290] cdr.c: CDR simple logging enabled.
[2013-06-28 16:56:16] VERBOSE[23290] config.c: == Parsing '/etc/asterisk/cel.c
[2013-06-28 16:56:16] ERROR[23290] config.c: The file 'cel_general_additional.co
robya
 
Posts: 7
Joined: Fri Apr 01, 2011 6:25 pm

Re: FOP2 error after upgrade to FreePBX 2.11

Postby admin » Mon Jul 01, 2013 6:33 pm

Hi,

Installing fop2admin or not, or any other freepbx module, cannot produce an error as "unable to connect to asterisk manager". It seems you have a different manager password set in /etc/asterisk/manager.conf than the one that you have in /etc/amportal.conf or similar file.

It is totally unrelated to fop2admin or fop2. It is a freepbx issue. In any case, be sure to install the latest FOP2Admin (1.2.13) that will work fine on recent FreePBX versions, and remember that the Queue and Park modules are prerequisites, you have to install them first.

Best regards,
Nicolás
admin
Site Admin
 
Posts: 3108
Joined: Tue Jun 23, 2009 11:26 am


Return to Installation and Configuration

Who is online

Users browsing this forum: Google [Bot] and 1 guest