Ability to give admin rights to only certain mailboxes

  1. 7 years ago

    It would be nice to have the ability to give admin rights to only certain mailboxes. We have an emergency mailbox that everyone accesses to listen to voicemail. It would be nice to click on the mailbox through fop and listen to the voicemail. I do not want to give everyone voicemailadmin rights.

    Thanks
    -Dimitry

  2. admin

    23 Dec 2011 Administrator

    You can create a custom permission to do that, if using fop2admin

    1. create a fop2 group that contains only the emergency mailbox
    2. create a custom permission with some unique name, like "emergencymailbox", add the voicemailadmin permission to it, and check the group you created on step 1
    3. edit a user and assign/add your custom permission "emergencymailbox"
  3. That is great!

    Thank you

    -Dimitry

  4. 3 years ago
    Edited 3 years ago by kelmore

    I can't seem to make this work correctly. The call center group can't access any voicemail as soon as I set all this up. Could you please review how I have this set up?

    I see now you instruct in 3 above to add this permission to a user, but I would assume it should work from a template as well, right?
    Fop 2.31

  5. admin

    2 May 2016 Administrator

    Edit a user, what permissions do you see selected for that user? (I do not see them on any screenshots). Alternatively, you can verify by running /usr/local/fop2/autoconfig-users.sh and look at the user=xxx line, particulary the permissions listing for every user.

  6. The user seems to have the correct permission.

    user=6603:6603:check_queue_voicemails,browser,callhistory,check,dial,hangup,hangupself,other,phonebook,pickup,preferences,queueagent,queuemanager,transfer,transferexternal,voicemails:All Queues,Call Center,Queue Voicemail Extensions:autowrapup,browser,callhistory,changepassword,clock,presencepause,queuecounter,queuelogin,configonreload

  7. admin

    3 May 2016 Administrator

    It should work if the perm=check_queue_voicemails includes correct channel/buttons. The only 'strange' see I see is that you are checking queue mailboxes, something that does not come 'naturally' in Asterisk and that was added recently into FOP2 (ability to define mailboxes for queues and not extensions). I will try to replicate the setting and see if it is something not covered being its a queue mailbox and not an extension mailbox.

    Best regards,

  8. I believe we have some virtual extensions set up, and have added them as users / buttons. We labeled them Queue Voicemail - Billing, etc It seems we are using extension mailboxes, but maybe we're approaching this incorrectly.

    I looked around and could not find any documentation for defining mailboxes for queues in FOP2, where can I do this?

    From your Number 1 above: "create a fop2 group that contains only the emergency mailbox" - How have you set up this emergency mailbox?
    Thanks!
    Kevin

  9. admin

    6 May 2016 Administrator

    If your mailboxes are not in queue buttons, then disregard what I said before as it does not apply to you.

    I have just replicated your configuration/setup, and it works perfectly fine. The only difference is that I did not use Queue Voicemail for the group name, but I do not think it will make any difference ( I used Some Test Group as a name, using spaces in the name to see if that were causing any issues).

    So, your setup appears correct and it should work fine, unless you do not have the last #exec line and configured things by hand in fop2.cfg

    Try to catch me on the live help so I can review your system.. best regards,

  10. This is now resolved. I was missing the definition of the custom permission I had defined.

    The output of /usr/local/fop2/autoconfig-users.sh should include, in the Permissions section:
    perm=check_queue_voicemails:voicemailadmin:VIRTUAL/399,VIRTUAL/299,VIRTUAL/199

    Initially I could not get these permissions to work as there were no extensions defined. It simply read:
    perm=check_queue_voicemails:voicemailadmin:

    We re-created the custom permission, checked the output of autoconfig-users.sh and all was working properly. Thanks for the help!

or Sign Up to reply!