Help w/ CentOS 6.3 x64, Asterisk 1.8.17, & FPBX 2.9

  1. 6 years ago

    Logging into FOP2 gets me a blank page with only "Filter, Dial, & Presence" at the top...
    I've tried redownloading & reinstalling to no avail, and it did take my license (just purchased)

    Help?
    - J

    This is using:
    fop2-2.26-centos5-x86_64.tgz & fop2admin-1.2.11.tgz
    w/ Visual Phonebook (database looks clean as far as I can tell)
    w/ FOP1 renumbered port to 4444 (works fine)
    on CentOS 6.3 x64 w/ FPBX 2.9.0.12

    Per instructions, tried (sperately):
    ln -s /usr/lib64/libcrypto.so.1.0.0 /usr/lib64/libcrypto.so.6
    ln -s /usr/lib64/libcrypto.so.10 /usr/lib64/libcrypto.so.6

    /usr/local/fop2/fop2_server --test
    Flash Operator Panel 2 - White Label Version.
    Flash Operator Panel 2 - White Label License (3)
    ERROR 1267 (HY000) at line 1: Illegal mix of collations (utf8_general_ci,IMPLICIT) and (utf8_unicode_ci,IMPLICIT) for operation '='
    Connection to manager OK!

    perl --version
    This is perl, v5.10.1 (*) built for x86_64-linux-thread-multi

    netstat -lnp | grep 4445
    tcp 0 0 0.0.0.0:4445 0.0.0.0:* LISTEN 12760/fop2_server

    netstat -lnp | grep 4444
    tcp 0 0 0.0.0.0:4444 0.0.0.0:* LISTEN 12709/perl

    uname -r
    2.6.32-279.el6.x86_64

    asterisk -rx "core show version"
    Asterisk 1.8.17.0 built by root on a x86_64 running Linux on 2012-11-02 20:09:04 UTC

  2. admin

    8 Nov 2012 Administrator

    Run the two autoconfig scripts and see which one is giving you an error:

    /usr/local/fop2/autoconfig-users-freepbx.sh
    /usr/local/fop2/autoconfig-buttons-freepbx.sh

    It is a warning from mysql due to mixed collations (character encodings).

  3. Yeah, I opened a rather long support ticket w/ you @ asternic where you can see the steps I took to identify and solve the issue, for search purposes...

    asterisk.fop2buttons was in utf8_general_ci whereas everything else was in utf8_unicode_ci, causing an issue with the (rather long) sql statement in autoconfig-buttons-freepbx.sh w/ comment "#si no tiene device and user, exclusimos los USER/"

    The fix was to update the database w/:

    alter table `asterisk`.`fop2buttons` convert to character set utf8 collate utf8_unicode_ci;

    ...and now the buttons.cfg is being generated correctly and users can now view fop2. I'm not sure why or how fop2buttons got to be put into utf8_general, but this has fixed me up... hopefully this will help you with other installs as well.

    Thanx Nicolas :),
    - J

    FYI: I've automated the install of FOP2, and have used the same identical process on a variety of systems (all CentOS 5 x86 though)... this was the first time I've ever had issues, figured it was yet another CentOS 6.3 x64 thing (as it was my first attempt on the new OS).

  4. admin

    10 Nov 2012 Administrator

    Thanks for the update and posting the fix!

or Sign Up to reply!