fop2 server problem

  1. 3 years ago

    Hello,
    Sometimes function "set presence" doesn't work. In normal way i see "Set Presence->Available,Do not Distrub, etc." and it works.But sometimes i just see "Set Presence" and no subparagraphs.I refresh page in web-browser and it works again.

    Also I tried to use "/usr/local/fop2/fop2_server --test" but nothing happened
    and i see "File does not exist: /var/www/html/fop2/fop2-variablesGENERAL.txt" error in httpd log files eveytime
    I tried to reinstall FOP2 but stucked on "make install" command,just nothing happens

    FOP2 v. 2.29.01 Licensed

    Sorry for bad English,i hope that's clear.

  2. admin

    3 Oct 2015 Administrator

    Hi,

    The fop2-variablesGENERAL.txt not found is normal, and not an issue at all. A fop2_server --test won't fix things, it will just test your license and the asterisk manager connection.

    Your problem is with a specific plugin, not even the core of fop2 feature. The problem description is clear, but it is hard to work on a fix if the problem cannot be reproduced somehow. Perhaps there is a specific chain of events/actions that leads to the presence options to be cleared. If that can be determined, and the problem can be reproduced, then I will be able to work on a fix.

    Maybe you are doing changes and applying them when that happens? Is there any action being done that leads to that issue?

  3. Thank you for answering. Actually is not my FOP2,so i can not say about any changes.Is there any logfiles or may be troubleshooting?Any advice will be usefull.

  4. admin

    6 Oct 2015 Administrator

    This is a minor glitch on the UI, something like won't be 'logged' as such as it is probably not an actual event or result of an action. If you are curious how to debug FOP2, this article will help:

    http://support.asternic.biz/?/selfhelp/view-article/how-to-debug-fop2/10

    Best regards,

or Sign Up to reply!