Upgrade not worked

  1. 3 years ago

    I have just purchased an annual upgrade license and applied it successfully:

    Reactivation Successfull

    Thanks! Do not forget to restart fop2 to activate the license.
    [root@beckpbx fop2]# service fop2 restart
    Shutting down Flash Operator Panel 2: [ OK ]
    Starting Flash Operator Panel 2: [ OK ]

    However when I try to upgrade from 2.28 to 2.30.06 by running make I get:

    /bin/sh: line 9: server/fop2_server: cannot execute binary file

    Upgrade Aborted. License reactivation failed.

    Be sure you have internet access from this server,
    and that your code is not older than a year.

    If your license has expired, you must renew it in order to upgrade,
    or you can still use your current FOP2 version for as long as you want.

    If you already bought an upgrade code please run the following command:

    server/fop2_server --upgrade

    If the upgrade is successful run make again to retry the installation.

    Contact us at sales@asternic.biz for more information.
    Done!

    So I can't do the upgrade. Any help would be appreciated.

  2. admin

    30 Apr 2016 Administrator

    Please download the tar.gz from the server, extract it on the server, and run make on the server. If you download on some other computer and then upload files via scp or ftp, you will lose file permissions that might lead to the exact error your are showing, among others.

    Best regards,

  3. I've just tried that with the latest 2.31 by downloading it directly using wget. I untarred the file and tried the "make" again and it failed in exactly the same way.

  4. Edited 3 years ago by admin

    I found out that the original FOP2 registration was: xxxxxxxxxxxx

    Lee

  5. admin

    3 May 2016 Administrator

    Hi Lee, please do not post activation codes on a public forum. Contact me via the live help, if you see an error about not able to execute fop2_server then it is because it lacks execute permissions, the directory you downloaded is mounted with noexec flags, or perhaps you downloaded the incorrect version (32 bits over a 64 bit OS or viceversa).

    I am online at the live help now if you want to chat.

    Best regards,

  6. Sorry about that. I contacted you via e-mail and this forum and you ask for the activation code which I posted her by mistake.

    It looks as if I downloaded the 64-bit version when the 32-bit version was needed.

or Sign Up to reply!