FOP2 2.31.01 is unregistered after OS update/reboot

  1. 3 years ago
    Edited 3 years ago by mkeuter

    Hi, I am using the AstLinux Linux/Asterisk distribution together with FOP2.

    The distribution is firmware based. When I update AstLinux and reboot, FOP2 is then unregistered most of the time (after registering again it usually works then).
    This is very annoying for my/your paying customers (and for me as well).
    This problem didn't happen with v.2.28. I remember a similar FOP2 support case of one of my customers (MGOL-027050 from March 2016). It had something to do with EXT2/3 partitions.
    On AstLinux the first partition is always a FAT16 partition (with the bootloader and system image), but the 2nd (and optional 3rd) partition(s) are always EXT2 formatted. The hard disk itself does not change after installation. Here it is explained:

    https://doc.astlinux.org/userdoc:system-boot-process

    Michael

    Update: FOP2 2.31.01 is also sometimes unregistered after a simple reboot!

  2. admin

    27 Jul 2016 Administrator

    Yep, the problem is that the filesystem returns a different hard drive file system id after every reboot, so it breaks the license system (because of FAT16, something that does not happen with ext2/ext3). It is like changing the hardware mac address after every reboot. It is not a simple problem to fix. A workaround would be to run a script to revoke the license on system shutdown, and register on system boot. With Amazon EC2 some people used that schema when EC2 did not have the option for static mac addresses. The ultimate solution would be to extend/adapt the FOP2 license mechanism no that kind of flash filesystem.
    best regards,

  3. OK. So why don't you simply check for a second partition if the first is FAT16? It it always there, has a label of "ASTURW" and it is ext2.
    If you like, you can also check for AstLinux: if "/etc/astlinux-release" exists, the system is running AstLinux. With version 2.28 the license system worked fine on all of my customer boxes. Can it have to to with 32-/64-bit, we recently switched new systems to 64-bit?

    Can you not check for the MAC-address of the NIC instead? This is static.
    The revoke script would need a working internet connection, right? But sometimes the customer reboots because of problems with the internet, so this would not be a foolproof solution.

    The partition UUIDs stay always the same after rebooting or upgrading (UUIDs faked):

    blkid
    /dev/sda1: SEC_TYPE="msdos" LABEL="RUNNIX" UUID="abcd-efg" TYPE="vfat"
    /dev/sda2: LABEL="ASTURW" UUID="12345-67890" TYPE="ext2"
    /dev/sda3: LABEL="ASTKD" UUID="23456-78901" TYPE="ext2"

    Michael

  4. Nicolás, if there is anything we can do in AstLinux to help you let us know.

    It would seem you are not using "blkid" to obtain the UUID of the disk media.

    Lonnie

  5. admin

    27 Jul 2016 Administrator

    Well, I will have to install an astlinux system and work on it to make the license check compatible with it, without breaking license for the current non astlinux userbase. Will try to do it whenever I have time.

    Best regards,

  6. Edited 3 years ago by abelbeck

    You can spin up AstLinux in a VM ...

    AstLinux Project
    http://www.astlinux-project.org

    One idea, add a new additional method using "blkid" to obtain the UUID, then allow either the current disk media check or the new "blkid" check to pass the test. Only if they both fail does your disk test fail.

    I'm sure this will help other paying users on other platforms as well.

    Edit: you can install an arbitrary FOP2 version by using the CLI command in AstLinux:

    upgrade-package fop2 upgrade http://path-to/fop2-2.31.01-debian-x86_64.tgz

    But note that a SHA1 fop2-2.31.01-debian-x86_64.tgz.sha1 file must also exist at that location.

    Nicolás, if you added the "blkid" test, I'm sure Michael would be happy to test it for you, no need to install AstLinux yourself if you don't have the time.

  7. admin

    28 Jul 2016 Administrator

    Hi,
    Try this new server binary, first revoke then replace the fop2 server binary and register the license, then reboot a couple or more times and see if the license sticks.

    http://download.fop2.com/fop2_server_debian_32
    http://download.fop2.com/fop2_server_debian_64

    I will have to test myself on non astlinux systems and try to be sure it does not break the license before releasing it in 2.31.03.

    Best regards,

  8. Edited 3 years ago by mkeuter

    I tried it, but I cannot revoke or again register it:

    License Revoke (or Activiation)
    --------------
    
    Enter your serial code: xxxx
    
    Serial code not available for revocation on this machine! 

    Update: I upgraded from 2.31.01 to version 2.31.02 now, but still cannot revoke the license. And your new testversion always run as Lite version without revoking, so I cannot test the new version. But version 2.31.02 (official version) behaves better on reboots now.

  9. admin

    28 Jul 2016 Administrator

    I do not know your activation code. Please come to the live help or open a ticket at http://support.asternic.biz requesting a manual revocation so you can test it out.

  10. OK, I created a ticket.

  11. Hi Nicolas,

    thanks --register has now worked (after manual revocation) with the new server-binary version for AstLinux. The license sticks now on my testbox (64-bit)!

    I rebooted 4 times including upgrading, downgrading and upgrading again. Thanks a lot for your quick help. I hope this new server version still works with non AstLinux systems. It would be great to have this addition in the next official FOP2 version.

    Michael

  12. admin

    29 Jul 2016 Administrator

    I will push the change and hope for the best :)

or Sign Up to reply!