One moment please

  1. 2 years ago

    Using the latest FOP2 with 100 user Elastix 2.5
    I keep getting "One moment please" Connecting to server attempt number: 1
    It will eventually go to login with Chrome, after maybe 2 or 3 minutes, however we have to use Internet Explorer 11 for our company.
    I have disabled FOP1 and I have read older posts relating to websockets.
    i can't find anything for the latest version on how to resolve this.
    We have used the old FOP1 for years with Elastix running on 1.6.
    After upgrading to 2.5, I am in search of a working operator panel that can be accessed by users without them logging in to the Admin portal.

  2. Are you connecting with the FQDN or with an IP address?
    Sounds like you may have an issue with DNS or with your gateway.

  3. I've tryed both ways. https://servername/fop2 and https://serverip/fop2. The DNS resolves to the IP of the server name.

  4. I have it working now. Changed FOP2 to use HTTP.

  5. admin

    24 Feb 2017 Administrator

    You must be sure to configure ssl certificate and key on fop2.cfg in order for latest fop2 to work with modern browsers using https. Without it it will fallback to flash after several tries. So, you can use https bug only if you configure the ssl certificates appropriately in fop2.cfg

    As you say you are using latest FOP2 on Elastix 2.5, if you happen to upgrade from FOP2 2.25, then you most probably are using an old fop2.cfg in /etc/asterisk/fop2 instead of the newer one with the ssl entries in /usr/local/fop2/fop2.cfg

    If that is the case, you can edit the /etc/sysconfig/fop2 file and remove -c /etc/asterisk/fop2 from the OPTIONS line so next time you start FOP2 it will read configs from /usr/local/fop2/fop2.cfg that should be the newer ones if you upgraded to 2.31.x for example.

or Sign Up to reply!