FOP stops working after converting PBX from physical to virtual machine

  1. last year
    Edited last year by Voipuser7

    I recently converted my FreePBX box from physical to virtual machine. After this, FOP2 stops running.

    When I run: "service fop2 status", I get this message:
    "fop2_server dead but subsys locked"

    When I run "service fop2 restart", I get this message:
    "Shutting down Flash Operator Panel 2: [FAILED]"
    "Starting Flash Operator Panel 2: [OK]"

    When I visit the web gui address: 192.168.1.2:8088/fop2/, I get the "One moment please spinning circle"

    Update:
    It seems this is concerning licensing issue. After I converted the physical machin to virtual, the license is now invalid. Here is the test command:
    /usr/local/fop2/fop2_server --test -i eth1
    Flash Operator Panel 2 - Invalid license for this machine.
    Running in Demo Mode
    Connection to manager OK!

    Please advise. Thank you!

  2. Hello, you need to unistall the fop2 from physical machine and then install on the virtual, if you have active support, you can re-host the license from physical to virtual w/o reinstall.

    Regards.

  3. On the old system run:
    /usr/local/fop2/fop2_server --revoke

    And then on the new system run:

    /usr/local/fop2/fop2_server --register

    You will be prompted for your license codes in both cases.

or Sign Up to reply!