button_custom.cfg not handled correctly

I have two FreePBX servers and am adding the remote server extensions to the primary. On the remote server I ran;
Which generates all the button details.

I then put that into the primary servers buttons_custom.cfg

For the most part it worked. However,queuechannel doesn't seem to be handled correctly.
label=John Smith
queuechannel=Local/2001@from-queue/n|Penalty=0|MemberName=John Smith|StateInterface=SIP/2001&Local/2001@from-queue/n|Penalty=0|MemberName=John Smith|StateInterface=SIP/2001|Queue=2096&Local/2001@from-queue/n|Penalty=0|MemberName=John Smith|StateInterface=SIP/2001|Queue=2097
autoanswerheader=__SIPADDHEADER51=Call-Info: answer-after=0.001


As you can see in FOP2Manager it cuts off after the word Penalty. What I'm experiencing is that these extensions aren't 100% working. For instance when I try to use the pause/unpause at the extension it doesn't work.

I also have had an issue with the queues defined in buttons_custom.cfg. Initially they would not show up. After reading on this forum a bit I tried editing [SIP/2097] to [SIP/2097^xxx.xxx.xxx] which didn't work. I then went back in and changed it back and magically the queues showed up.

FYI, yes the buttons were added to a group and should have been visible. Something isn't right here.


  • Really strange. This happens in exactly the same way on both of my FOP2 installs.

    The first time I populated buttons_custom.cfg and reload FOP2 none of the queues showed up and I couldn't pause/unpause agents at the extension level (helpful to pause/unpause in ALL queues).

    I fixed the queue behavior as I mentioned above. However with what I just figured out it might have been a side effect of causing the button to be "removed" and "re-added".

    I moved the buttons_custom.cfg file out of /usr/local/fop2 into my home folder. I then reloaded FOP2 and went into the FOP2 Manager -> Buttons to make sure they were gone (they were). I then moved the file BACK to /usr/local/fop2 and reloaded FOP2. Went into FOP2 Manager -> Buttons and the buttons showed up again. I went to Groups and added them back to the group I created for them. At this point I was back to where I was before, the buttons showing up in FOP2. HOWEVER NOW THE PAUSE/UNPAUSE WORKS!!!

    The queuechannel field in FOP2 Manager STILL does not show up correctly! So there could possibly still be an issue I'm not aware of.

    I suspect that simply removing and re-adding the buttons_custom.cfg file might have solved both problems with the queues showing up and the pause/unpause at the extension level. Because what I had done by changing the queue from [SIP/2097] to [SIP/2097^xxx.xxx.xxx] was to remove the button, and then when I changed it back I was re-adding it.

    I still think something is wrong here. While it appears "fixed" for me, something stopped this from working correctly on initial creation. I'm not sure if the problem might resurface again if I try to add a new button for an extension on the remote system (who is a member of a queue) to buttons_custom.cfg.
  • Well, still having 1 problem. Call Pickup from a queue on the remote PBX doesn't work. It does however work if I drag the call to my extension. Not sure why that isn't working.
Sign In or Register to comment.