FOP2/LetEncrypt issue?

It's been a while since we last installed FOP2. Just added it to an existing system with the one-command install. I can get to the FOP2 admin panel, but the user interface just spins at "connecting to server" and then times out.
We've tried many different settings for the SSL cert and key in fop2.cfg. The docs are not consistent and none are working for us, including:
/etc/asterisk/keys/integration/certificate.pem (this is what is in Advanced Settings in FreePBX for TLS)
We are using the LetsEncrypt management built into FreePBX. Everything else is working fine, including the FreePBX admin and UCP, and the FOP2 admin panel.
grep ^SSLCertificate /etc/httpd/conf.d/* returns nothing.
I added a custom service for TCP/4445 in the FreePBX responsive firewall.
I ran sudo iptables -I INPUT -p tcp -m tcp --dport 4445 -j ACCEPT
I cannot telnet to port 4445 on the system. Not sure if that should work or not.
Appreciate any input from someone who has this working.


  • I'm facing the same issue, I have everything setup, but FOP2 cant setup the WSS connection, the page and cert works good on Apache2. I can telnet to the 4445 from external and internal networks, but the WSS doesn't work.

Sign In or Register to comment.