Queue pause from presence box - agents unpausing

  1. 3 years ago

    We are using the above plugin so that agents can pause themselves from the presence box but have also uncommented the pause states section in presence.js. However when agents pause themselves they seem to get unpaused automatically and then have to put themselves back on pause. This happens pretty regularly but seems random.

    Any guidance on where to look to investigate this issue would be great.

    Thanks

    Lee

  2. admin

    9 Dec 2015 Administrator
    Edited 3 years ago by admin

    Do you have the auto wrapup plugin installed? That is the only plugin that can unapuse an agent automatically. Any other unpause action should be actuallly issued , either by features codes in your dialplan, or from FOP2 itself. You can enable the audit log in FOP2 if you want to track unpause actions fired from within FOP2.

    To enable the audit log edit /etc/sysconfig/fop2 and set something like this:

    OPTIONS="-d -a /var/log/fop2_audit.log"

  3. Thanks for this and sorry for the late reply. I haven't tried the audit log yet but will do. One thing that we have noticed is that if agents pause themselves using the "Pause Member" menu then all works fine and they stay paused. If they pause themselves using the Presence menu they become unpaused a few seconds later.

  4. admin

    19 Jan 2016 Administrator

    How do you check if a member is paused? Via the FOP2 GUI only? Have you checked the output from

    asterisk -rx "queue show"

    ?

  5. Yes via the FOP2 GUI but also Asternic reports show the UNPAUSE. In addition the agents do still receive calls from the queue so even though I haven't actually see the output from asterisk "queue show" they are seen by Asterisk as unpaused.

    I will see if I can do an asterisk "queue show" the next time this happens.

    Lee

  6. admin

    19 Jan 2016 Administrator

    Are you using the queuelogin plugin?

  7. It's installed but we're not using it at the moment. But we do intend to start using it soon.

  8. admin

    19 Jan 2016 Administrator

    You might have some application unpausing queue members. FOP2 does not do that automatically. Autowrapup plugin does that, so if you do not want automatic pause and unapause be sure to not use that plugin if you have it.

  9. We did indeed have the auto-wrapup plugin installed and have now removed that temporarily to see if that makes any difference.

    Thanks

    Lee

  10. admin

    20 Jan 2016 Administrator

    It will make a difference, the auto wrapup plugin will pause automatically after a call is finished, and unpause after a configured time (via plugins settings in the fop2 manager).

    Best regards,

  11. I think that fixed the issue that we were having.

    Thanks

or Sign Up to reply!