Dial Button and Dial Box Don't Ring Phone

Hi There;

I just updated to asterisk 1.8 which resolved most of the issues I was having with FOP2, however, I can't get the dial button or the dial box to work properly. If I select another extension and press the dial button, nothing happens; it does not ring my phone to initiate the connection and no commands are sent to asterisk. This is the same if I enter a number in the dial box. The dial box does work for transferring, ie. if I'm on a call, enter a number in the dial box and hit enter, it transfers the call to that number so the problem seems to be with just originating a new call to my phone.

I have my fop2admin AMI user setup for "all" read/write permissions and I have tried adding in "originate" and "dial" in addition to "all" to see if it makes a difference, but it doesn't.

The FOP2 user I am using has "all" rights and all other functions seem to work properly.

This isn't a huge deal as most of the users don't use FOP2 to operate their phones, however I would like to get this working in the event the users decide to make use of this feature.



  • You must add the "originate" permission to your /etc/asterisk/manager.conf user in read/write lines.
  • Hi There,

    As I had previously stated, I had tried that to no effect. My FOP2admin user (I'm not using the default AMI admin) currently has read/write permissions of "originate, dial, all".

    Full User info the manager.conf file:
    secret = secret
    permit =
    read = originate, dial, all
    write = originate, dial, all
    writetimeout = 1000
    eventfilter = !Event: RTCPSent
    eventfilter = !Event: RTCPReceived
    eventfilter = !Event: VarSet
    eventfilter = !Event: Cdr
    eventfilter = !Event: ExtensionStatus
    eventfilter = !Event: ChannelUpdate

    AMI info in my fop2.cfg file is:

    And it is definitely logging in OK with that user considering everything else works.

    I fired up logging in fop2 and this is what I get when I try to run the dial command:
    Action: Originate
    Channel: local
    Exten: XX
    Context: from-internal
    Priority: 1
    CallerID: TV01 Test <9998>
    Async: True
           -> Action: Originate       -> Channel: local       -> Exten: XX       -> Context: from-internal       -> Priority: 1       -> CallerID: TV01 Test <9998>       -> Async: True
    ** MAIN End of block from localhost       <- Response: Error       <- Message: Invalid channel       <- Server: 0
    ** MAIN AMI event received...
    ** MAIN No 'Event' nor 'End'. Erasing block...
    Response: Error
    Message: Invalid channel
    Server: 0

    So I'm not sure what it is referring to with "Error Invalid Channel". It is the same with internal extension or external numbers.

  • What is that "local" for channel? That comes from somewhere. It is not standard, it is something you configured in some place and it is wrong. maybe your originatechannel in button configurations is set to "local" instead of "Local/XXX@from-internal" or similar. You have to fix your config.

    Best regards,
  • Hi,

    The problem was that I hadn't configured anything. With the FreePBX FOP2 admin module, if you don't configure anything specifically for the originate channel in the buttons, what it generates is what I posted in the logs. I manually entered in the originate channel for each extension in the FreePBX admin as local/xxxx@from-internal and this resolved the issue.

  • Hi,

    You do not need to enter anything in fop2 admin, unless you use device&user mode in FreePBX (that is not the default mode in freepbx installs).

    Best regards,
  • Seems this is still an issue. I am not using device&user as we are in the PJSIP era now, and the FOP2 dial box won't dial numbers, and selecting a button and pressing dial button doesn't work either. I notice in FOP2 Admin / Buttons that all "originate channel" fields are empty. I filled my extension button's "originate channel" with "local/100@from-internal", reloaded asterisk and FOP2 and it still doesn't work... Any ideas?

  •            <- Event: OriginateResponse            <- Privilege: call,all            <- Response: Failure            <- Channel: local/221@from-internal            <- Context: from-internal            <- Exten: 9164965291            <- Reason: 3            <- Uniqueid: <unknown>            <- CallerIDNum: 221            <- CallerIDName: Mike Hechtman
  • One thing to note is that this did work about a year ago :/

Sign In or Register to comment.