Editing Users (on FreePBX)

Hi,

I setup FOP2 and everything seems to be in order. All my FreePBX extensions are showing (15 buttons on non-license mode).
My question is how do I edit the User setting.
When I clicked on the left pane Users menu, on the right side a list of FreePBX users are listed.
But when I click on the individual user itself, nothing is showing.

I tried creating new user from FOP successfully.
But the newly created user is also not editable.
When I click the red "x" sign to delete the user, it is also not deleting the user.
Is there anything I missed?
I notice on the Dashboard a message
PHP SQLite module not installed.

Is that related?

Regards,

Rusman

Comments

  • Yes, that is related, you must install that module.

    Best regards,
  • Hi,

    Maybe we face the same problem?

    I'm running FreePBX 13.0.167 on a Raspberry Pi (RasPBX). Everything is updated to the latest version.
    FOP2 is running fine, but I discover that after updating FOP2 Manger to version 1.1.3, users can not be edit anymore. 1.1.1 and 1.1.2 worked just fine. A user can be created, deleted, but selecting it to edit, the right part of the screen that normally shows the current settings is blank. No error is shown.

    Best regards,
  • Same response.. if you cannot edit a user is because there is no php-sqlite support. The latest version of the manager allows you to set user preferences from the manager itself, and for that the sqlite database is updated and the driver needed. Errors will be shown if you look at the web server error log file. You can also enable debug in /var/www/html/fop2/admin/config.php and you might see errors directly on screen.

    Best regards,
  • We have the problem after updating FOP2 Manager to version 1.1.3. It was done from the FOP2 Manager URL, after it suggested the update that was available. Update went just fine, no errors...

    Can you confirm that FOP2 Manager - Version 1.1.1 and 1.1.2 did not need PHP SQLite?
    in config.php I changed value 0 after $Debug to 1 and opened the admin URL for FOP2
    I see two messages:

    1. in the topbar on the right. It says: /var/www/html/fop2/admin/menu.php (line 108)
    Undefined index: action

    2. In the left menu bar. It says:

    Otherwise no messages. Selecting an existing user, ends up with a blanc display. However a new user can be created and an existing user can be deleted. So for now changing the rights is deleting the existing user and then add it again with the new settings....

    Best regards,
  • Latest version SQLite is in place.

    XXXXXXX:~# sudo apt-get install sqlite3

    Reading package lists... Done
    Building dependency tree
    Reading state information... Done
    sqlite3 is already the newest version.
    The following packages were automatically installed and are no longer required:
    libgssapi3-heimdal libheimntlm0-heimdal libkdc2-heimdal
    Use 'apt-get autoremove' to remove them.
    0 upgraded, 0 newly installed, 0 to remove and 2 not upgraded.
  • Sorry, forgot the message:

    2. In the left menu bar. It says:

    /var/www/html/fop2/admin/menu.php (line 244)
    Undefined index: action

  • Using Inspect Element in Chrome, I see this error message when selecting a user to edit. Otherwise the message is never shown...

    fop2manager.js:292 Uncaught TypeError: $(...).bootstrapSwitch is not a function

    (anonymous function) @ fop2manager.js:292
    c @ jquery-1.10.2.min.js:4
    fireWith @ jquery-1.10.2.min.js:4
    ready @ jquery-1.10.2.min.js:4
    q @ jquery-1.10.2.min.js:4
  • If you see that message it means the FOP2 Manager was not correctly upgraded/installed. Most probably because the directory owner is not the web server user, and the upgrade was incomplete. If you use FreePBX be sure that /var/www/html/fop2/admin and all files withing are owned by the 'asterisk' user, then you will have to redownload the FOP2 manager so it gets installed correctly. If ownership is not correct, then *NEW* files won't be saved and you will get errors like the one you are seeing.

    To force a redownload of the file, edit /var/www/html/fop2/admin/system.php and set version to a lower number, like 1.1.2 or similar.

    Best regards,
  • Also, you must install sqlite support * for php * , not just sqlite. There is a specific module for PHP. You *will* see an error related to that in your web server error log (or php error log if you have it defined as separate). That error is visible only *on the server*, not on the javascript console.

    Best regards,
  • Ok,

    I'll try.

    Can you confirm that FOP2 Manager - Version 1.1.1 and 1.1.2 did not need PHP SQLite support, because those two versions worked just fine. Also after updat 1.1.1 to 1.1.2

    Where should I look *on the server* for the error message?

    Best regards,
  • Thanks, problem solved.

    Manager 1.1.1 and 1.1.2 did not have problem editing users without PHP sqlite support.

    Manager 1.1.3 does. I checked error log and found PDOExeption "could not find driver..."

    applying: sudo apt-get install php5-sqlite

    and restarting services everything is just fine.

    Best regards, Arend

  • Version 1.1.4 will just skip the user settings in the edit form instead of failing as 1.1.3 does when no sqlite support is found for php. So it would work even if you do not have the sqlite driver installed, but not showing the option to edit user preferences.

    Best regards,
  • I'm running Ubuntu, asterisk 13.18, freepbx, and just installed FOP2. I get the "PHP SQLite module not installed" error and I'm not able to edit users. Is sqlite required? (https://www.fop2.com/docs/installation.php#SystemRequirements does not indicate it is.) I installed "sudo apt-get install sqlite php-sqlite3" but no luck. Please confirm whether mysql or sqlite is used and how to eliminate the error and edit users. Thank you!

  • edited September 19

    Resolved! "php -m | grep sqlite" result was empty. I guess "sudo apt-get install sqlite php-sqlite3" didn't work. I used "php -v" to determine my php version (PHP 5.6.40-30+ubuntu18.04.1+deb.sury.org+1 (cli)), then did:
    sudo apt-get install php5.6-sqlite3
    service apache2 restart
    service fop2 restart

    php -m | grep sqlite
    now shows:
    pdo_sqlite
    sqlite3
    Now I can use the FOP2 Manager!

Sign In or Register to comment.