New Forum

edited February 2022 in Blog

Hi all,

The forum we were using was constantly being spammed by bots for new user registrations, in a rate that made it impossible for us to keep it clean. I was making some modifications on the forum code to try to clean this bots/spam atack, and tried to clean up the thousands of pending member aprovals (that I had to turn on because of the forum spam).

So, finally I got tired and decided to try a different Forum software, and did so with the only one I found that seemed reasonable modern/updated, with some spam/bot preventions built in and that could import the old forum data: VanillaForum.

I have no idea was this will turn up, maybe I will have to revert to the previous incarnation. I hope existing/validated accounts got imported correctly, I did some work to not lose old links from google searches. I still need to learn a bit about this and possible tweak permissions and configurations a bit.

New user registration does not require aproval any longer, and hopefully it will prevent bots from registering.

Please let me know how it works, if you have issues, etc. I hope to have a bit more time now for answering things instead of dealing with bots/spams.



  • I had to reset my password. But otherwise, I am not logged in.

    Obviously you already switched systems, but one of the best ones out there, IMO, is NodeBB. So if this one doesn't work right, you may want to look at it.

  • Is there no way to edit a post? I obviously typo'd now as not...

  • edited September 2019

    @JaredBusch said:
    Is there no way to edit a post? I obviously typo'd now as not...

    I think I have enabled permissions to edit now on this Category... it was not set before. As for the software chosen, it was mostly a matter of chosing the one with a simpler migration path preserving users, posts and such.

    Anyways, I still had to write a custom plugin to avoid spam/bot registrations in this forum as well, it seems reCaptcha is not effective any longer. I will keep monitoring status, and also will take a look at NodeBB. Thanks for the feedback.

    Best regards,

  • edited September 2019

    You have.

    Looks like it is a by category setting. I cannot edit one of my posts in another category (don't actually need to, as just checking).

  • Hi Nic
    Did all the posts come over to the new forum? I posted some last week that don't seem to appear. primarily abut the pause recording plugin and the paused members plugin.

  • Hi,
    Last week comments/posts should be here, but maybe the ones made on friday or yesterday were not imported, as I spent several hours until I decided to go with Vanilla as the import was at least possible. The old forum is still reachable at but it won't be up for long if I decide to keep this one.. and if I switch back, the content from the last couple of days with this forum software will be lost again.

    I found one of your post here and I think that one was made after the data export I tried.. You are welcome to write it again here if you want. Regarding the issue you describe with the plugin, yes, the lack of the new setting makes the plugin not to work, and that will happen if you upgrade the plugin without going then to the configuration button for it. I added some code to prevent that error from impacting on the plugin, and I wll think a way to update .ini files with new settings on upgrade, but that will take some time.

    Best regards,

  • edited April 2021

    @JaredBusch said:
    Looks like it is a by category setting. I cannot edit one of my posts in another category (don't actually need to, as just checking).

    I think I have now allowed edits as a default permission. Thanks for checking...

  • edited April 2021

    I just posted a query [Adding Extensions Trunks to Operator Panel - Demo version] and wanted to edit it but there is no such option.

    I then looked at the post below mine [Multiple AOR (PJSIP) for call and Listen] and the Comment there shows the 'gear' symbol. If I click on it and select Edit, I am allowed to edit someone else's comment. I added a 2nd full stop to the 2nd line. You can now see there are two.

    Edit: Here I can edit - and it looks like I can actually edit your comment above mine!!!

    Edit 2. I tried the button and the quote within the post became editable but not the last line of the post. I cancelled then tried again and this time the gear icon is not clickable.

    Edit 3. Tried again and this time it opened the whole post - I added two full stops.

  • Choosing a name for your Free Fire Name game character or team can be a fun and creative process. Here are some cool and catchy name ideas:


    Remember to choose a name that reflects your playstyle or personality in the game. You can also mix and match these suggestions or come up with your own unique name by combining different words or elements related to the game.

Sign In or Register to comment.