FOP2 server issues

Every couple of days i do get a complaint from my boss that he can't access the FOP2 panel. When i check the error on the bottom of the webpage i see that FOP2 reports that it can't connect over port 4445! The problem gets resolved by issuing the following command, (rm /usr/local/fop2/fop2settings.db) followed by restarting the FOP2 service. Is there a permanent resolution to this?!!

MORE INFO:
1- This is a licensed version of FOP2.
2-When i run the command (/usr/local/fop2/fop2_server -X 15 -i eth0) i get the following error
(server/fop2_server: symbol lookup error: /tmp/par-726f6f74/cache-42500eee0cc6d9b9f21916d9c1dace54f3fc476d/libssl.so.6: undefined symbol: CRYPTO_memcmp)
3- my /etc/sysconfig/fop2 has a line that states --> OPTIONS="-d --rp=http"

Any help is much appreciated.

Comments

  • Hi,
    Usually that libcrypto error is fixed by installing the openssl compat library as described in this entry in the FAQ

    If your OS does not have that library, or if the error still happens after installing it, then you must always use the --rp=http when running fop2_server, so, on step 2, you should run the command adding --rp=http at the end of the parameters list. Whenever you invoke ./fop2_server via the command line, you should add it, otherwise the fop2settings.db might get corrupted

    Finally, the error you experience might not be related at all with the fop2settings.db corruption you see. The way to troubleshot would be to add debug parameters to the /etc/sysconfig/fop2 file, something like

    OPTIONS="-d --rp=http -X 511 -l /var/log"
    

    and let it run with debug, once you notice the error, then look at the last lines on the log when there are connections attempts to FOP2, or in general look for any kind of errors, mostly you might want to check for the string "EV" on the logs.

    Best regards,

  • Well, it took a few days to fail this time, here is the offending part of debug:
    -- TIMER asterisk_ami_connect and async config check
    ** Asterisk Manager logged in localhost for 39969 seconds (Tue Oct 8 01:16:48 2019)
    -- TIMER asterisk_ami_connect and async config check
    ** Asterisk Manager logged in localhost for 39972 seconds (Tue Oct 8 01:16:51 2019)
    New client connection from socket AnyEvent::Handle=HASH(0xb808a44) - 51.91.212.81:43338

    Flash clients connected: 1

    [[33;40mClient 51.91.212.81:43338, user: no user, type: no type
    [[0m--------------------------------------------------------------------------------------------------

    Total: 1, Websocket: 0, XMLSocket: 0, Other: 1. Double logins: 0

    /usr/local/fop2/fop2_server: symbol lookup error: /usr/local/fop2/temp/par-726f6f74/cache-d06ce949f4d091dc3a4ef1a36d2c0d0793305d26/libssl.so.6: undefined symbol: CRYPTO_memcmp

    The openSSL098e is already installed:
    yum install openssl098e
    Loaded plugins: fastestmirror, presto
    Setting up Install Process
    Loading mirror speeds from cached hostfile
    Could not get metalink https://mirrors.fedoraproject.org/metalink?repo=epel-6&arch=i386 error was
    14: problem making ssl connection
    * epel: reflector.westga.edu
    * rpmforge: mirror.teklinks.com
    * sl: ftp.scientificlinux.org
    * sl-security: ftp.scientificlinux.org
    Package openssl098e-0.9.8e-20.el6_7.1.i686 already installed and latest version
    Nothing to do

    What do you think?

  • Hi,
    Never seen that happen, do you recognize the ip that connected to FOP2 before the problem? 51.91.212.81?
    Try uninstalling openssl098e (yum remove openssl098e) and always use --rp=htttp when running fop2_server, to see if it makes a difference.

    Best regards,

  • Well, it took a few days to fail this time, here is the offending part of debug:
    -- TIMER asterisk_ami_connect and async config check
    ** Asterisk Manager logged in localhost for 39969 seconds (Tue Oct 8 01:16:48 2019)
    -- TIMER asterisk_ami_connect and async config check
    ** Asterisk Manager logged in localhost for 39972 seconds (Tue Oct 8 01:16:51 2019)
    New client connection from socket AnyEvent::Handle=HASH(0xb808a44) - 51.91.212.81:43338

    Flash clients connected: 1

    [[33;40mClient 51.91.212.81:43338, user: no user, type: no type
    [[0m--------------------------------------------------------------------------------------------------

    Total: 1, Websocket: 0, XMLSocket: 0, Other: 1. Double logins: 0

    /usr/local/fop2/fop2_server: symbol lookup error: /usr/local/fop2/temp/par-726f6f74/cache-d06ce949f4d091dc3a4ef1a36d2c0d0793305d26/libssl.so.6: undefined symbol: CRYPTO_memcmp

  • Hi,

    Did you try to unisntall openssl098e as suggested in my previous post?

  • edited October 18

    it is one of the below ones...
    1- Your registration code for FOP2 Basic White Label is: xxxxx
    2- Your registration code for FOP2 Basic is: xxxxx
    3- Your registration code for FOP2 Basic is: xxxxx

    sorry, I thought I know which serial belongs to which server!

  • Plaease do not post activation codes or serials in a public forum.

Sign In or Register to comment.