Failure to install on Raspbx Buster

Downloaded the latest package, fop2-2.31.23-raspberry-arm.tgz. Untarred it. ran make install no errors. However starting the service fails.

systemctl status fop2
● fop2.service - LSB: Start fop2 at boot time
   Loaded: loaded (/etc/init.d/fop2; generated)
   Active: failed (Result: exit-code) since Wed 2020-03-18 10:33:41 GMT; 7s ago
     Docs: man:systemd-sysv-generator(8)
  Process: 21129 ExecStart=/etc/init.d/fop2 start (code=exited, status=2)

Mar 18 10:33:41 raspbx systemd[1]: Starting LSB: Start fop2 at boot time...
Mar 18 10:33:41 raspbx fop2[21129]: Starting Flash Operator Panel 2: fop2Can't load '/tmp/par-726f6f74/cache-a321f8be048aa2f840c00a3bb90a2a2588904510/9798ca90.so' for module Filter::Crypto::Decrypt: libcrypto.so.1
Mar 18 10:33:41 raspbx fop2[21129]:  at /usr/share/perl5/PAR/Heavy.pm line 123.
Mar 18 10:33:41 raspbx fop2[21129]: BEGIN failed--compilation aborted at /tmp/par-726f6f74/cache-a321f8be048aa2f840c00a3bb90a2a2588904510/inc/lib/Filter/Crypto/Decrypt.pm line 37.
Mar 18 10:33:41 raspbx fop2[21129]: Compilation failed in require at script/fop2_server.pl line 1.
Mar 18 10:33:41 raspbx fop2[21129]: BEGIN failed--compilation aborted at script/fop2_server.pl line 1.
Mar 18 10:33:41 raspbx systemd[1]: fop2.service: Control process exited, code=exited, status=2/INVALIDARGUMENT
Mar 18 10:33:41 raspbx systemd[1]: fop2.service: Failed with result 'exit-code'.
Mar 18 10:33:41 raspbx systemd[1]: Failed to start LSB: Start fop2 at boot time.

When running /usr/local/fop2/fop_server the following error occurs.

/usr/local/fop2/fop2_server --test
Can't load '/tmp/par-726f6f74/cache-a321f8be048aa2f840c00a3bb90a2a2588904510/9798ca90.so' for module Filter::Crypto::Decrypt: libcrypto.so.1.0.2: cannot open shared object file: No such file or directory at /usr/lib/arm-linux-gnueabihf/perl/5.24/DynaLoader.pm line 187.
 at /usr/share/perl5/PAR/Heavy.pm line 123.
BEGIN failed--compilation aborted at /tmp/par-726f6f74/cache-a321f8be048aa2f840c00a3bb90a2a2588904510/inc/lib/Filter/Crypto/Decrypt.pm line 37.
Compilation failed in require at script/fop2_server.pl line 1.
BEGIN failed--compilation aborted at script/fop2_server.pl line 1.

The latest version of libcrypto in Debian Buster is libcrypto.so.1.1. Can the dependencies be updated?

For reference. Raspbx distro

cat /etc/os-release 
PRETTY_NAME="Raspbian GNU/Linux 10 (buster)"
NAME="Raspbian GNU/Linux"
VERSION_ID="10"
VERSION="10 (buster)"
VERSION_CODENAME=buster
ID=raspbian
ID_LIKE=debian
HOME_URL="http://www.raspbian.org/"
SUPPORT_URL="http://www.raspbian.org/RaspbianForums"
BUG_REPORT_URL="http://www.raspbian.org/RaspbianBugs"

uname -a Linux raspbx 4.19.97-v7l+ #1294 SMP Thu Jan 30 13:21:14 GMT 2020 armv7l GNU/Linux

asterisk -V
Asterisk 16.7.0

cat /etc/raspbx/installed_version 27

Sign In or Register to comment.