WebRTC - Does it work with the latest FreePBX?

Does anyone know how to get the WebRTC plugin working on the latest FreePBX? The instructions provided in the WebRTC Guide seem to be specific to IssabelPBX and don't line up completely with the options available on FreePBX.

I have the plugin installed and the extension configured as close as possible to the example in the guide. When I load up FOP 2, the extension appears to register, as shown in FOP2 as well as in the asterisk logs, however it is not able to send or receive calls in any way. It just says "Trying ##########" in the UI and nothing at all in the asterisk logs. I cannot even cancel the call in the WebRTC UI, it just stays kind of frozen until I close the FOP2 page entirely and reload.

Comments

  • Minor update:
    I was loading FOP2 in HTTP but WebRTC needs HTTPS, so I fixed up the ssl configuration in fop2.cfg and reloaded in HTTPS. Now the WebRTC phone behaves slightly differently. Instead of getting stuck on "Trying ##########" it just immediately flips to Call Ended when trying to dial a number.
    When receiving a call it rings, I see the callerID, but when answering it immediately flips to Call Ended as well.
    So something is still not right... Any ideas?

  • edited September 30

    Another minor update:
    I got calls going through now by delecting a different Media Encryption and transport setting, but one way audio only, whether it's in out outbound calls. I can hear everything via the WebRTC client, but the other side doesn't hear anything. RTP debug in asterisk shows the right IPs and ports, and everything is being passed by the firewall. My browser is configured to allow microphone access as well.

    The settings within FreePBX I applied to the extension I am testing with are as follows, everything else is default settings:
    Transport: 0.0.0.0-wss
    Enable AVPF - Yes
    Enable ICE Support - Yes
    Enable rtcp Mux - Yes
    Enable WebRTC defaults - Yes
    Media Encryption - DTLS-SRTP (not recommended)
    Enable DTLS - Yes
    Use Certificate - I selected the real, not self-signed SSL cert configured for my server

    So what am I missing?

  • Final update for today:
    It would seem as though it DOES work! Just not in Google Chrome. For the heck of it I just tried it in Firefox and it worked first try.
    What would cause this to work in Firefox but not Chrome?

  • do you have latest fop2

  • @Edi said:
    do you have latest fop2

    Yep, latest FOP2, latest FreePBX and latest versions of Chrome and Firefox.

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Emoji
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file