Auto Answer not enabled in FOP2 WebRTC phone when set to YES in extension preferences.


When I set Auto Answer to Yes in an extensions preferences in the Panel Manager and then login with that extension on the FOP2 WebRTC phone the setting is not enabled. When I look at the user extension preferences the setting at Phone Auto Answer is set to ON but yet the WebRTC phone is still showing NO and have to slide it to YES.

Hope somebody can help.

Setting in Preferences in the Panel Manager

Setting on the extension itself

WebRTC Setting when login


  • Settings are not related. Auto answer in fop2 preference pane is for setting a header in the device when originating calls... it does not set auto answer in the device itself. Enabling auto answer in fop2 preference pane, and having a sip phone that accepts auto answer sip headers using chan_sip will make FOP2 use that header when ORIGINATING. a call from FOP2, so the user device auto answers before dialing the other leg.

Sign In or Register to comment.