Call recording name format incompatible with FreePBX 15

When I record a call within FOP2, it does correctly record the call and write the filename to the CDR record. Unfortunately, FreePBX 15 requires that the seperator be a - and not a _ now. Additionally, the call needs a field added prior the to the name ( i used fop2 in my manual test) and it needs the date. Once fixed, like this, the recording shows up in the CDR search as well as the UCP.
Original filename: 219_219_111806_1638551871.156513_GENERAL.wav
Working filename: fop2-219-219-20211203-111806-1638551871.156513-GENERAL.wav
The issue is how the CDR (and UCP as it worked but I haven't checked the code) finds the file.
https://github.com/FreePBX/cdr/blob/2969c0781e0322af94048380b6f3adde18f23621/Cdr.class.php#L489

Answers

  • You can edit the monitor_filename setting in /usr/local/fop2/fop2.cfg and change the name/format to whatever will suite your needs, default is:

    monitor_filename=/var/spool/asterisk/monitor/${ORIG_EXTENSION}_${DEST_EXTENSION}_%h%i%s_${UNIQUEID}_${FOP2CONTEXT}
    

    Maybe changing it to:

    monitor_filename=/var/spool/asterisk/monitor/fop2-${ORIG_EXTENSION}-${DEST_EXTENSION}-%h%i%s-${UNIQUEID}-${FOP2CONTEXT}
    

    will do the trick... Remember that whenever you modify fop2.cfg, you must restart FOP2 in order for the changes to take effect:

    systemctl restart fop2
    

    Best regards,

  • I can and will change this, thanks. But I think this also needs to be default if you want things to work with FreePBX still.

  • Ok, I will change the default filename for newer installations. However, as a note, note everyone uses FreePBX. Its hard to make sensible defaults that will work for all. Best regards,

  • Of course not everyone uses FreePBX. If this setting is not one that can have a good default based on deployed system, then maybe make a help note someplace so admins can know where to set this.

Sign In or Register to comment.