Extremely slow log in with 2.31.08

New install of 2.31.08 on FreePBX 13 is almost impossible to log in to with Firefox. It just spins and spins. Eventually the login will pop up and I can log in, but if I miss seeing it (because I tab over to something else) it will disappear back to connecting and then finally say server unavailable.

I have installed this on two different servers with the same result.


  • edited April 2017
    This solved the problem. Had to hit chat, to get the answer sadly.
  • I have added the portion about SSL on the installation guide (besides all the posts in the forums, knowledgebase and faq). Hopefully it will help others in the future. Best regards,
  • With my "old" elastix installation, this did not solve the problem... also updating today didnt help

    My Chromium Version 58.0.3029.96 Built on Ubuntu , running on LinuxMint 18.1 (64-bit)
    but also recently updated Google Chrome on various Windows Boxes complain about (Developer Tools in Chrome):
    - WebSocket connection to 'wss://pbx.cevavet.de:4445/' failed: WebSocket opening handshake timed out
    - Mixed Content: The page at 'https://pbx.cevavet.de/fop2/' was loaded over HTTPS, but attempted to connect to the insecure WebSocket endpoint 'ws://pbx.cevavet.de:4445/'. This request has been blocked; this endpoint must be available over WSS.

    and others. Chrome blocks flash and ws://... is marked as unsecure

    How can I debug deeper ?

  • If you have the ssl_xxx parameters set correctly in fop2.cfg, then IT WILL WORK. Perhaps you are editing the wrong fop2.cfg file as if you use Elastix and installed from RPM, then by default configuration files will be looked for on /etc/asterisk/fop2 instead of /usr/local/fop2. Another thing old FOP2 installs on elastix have is the configuration disableWebSocket in /var/www/html/fop2/js/presence.js set to true (it should be set to false).

    Also be sure you use FOP 2.28 or higher...

    To change the configuration location check the file /etc/sysconfig/fop2, if you see something like

    OPTIONS="-d -c /etc/asterisk/fop2"

    Then it indicates that you have configs on that directory, instead of /usr/local/fop2, so you should either modify the right config, or edit the OPTIONS line and leave it with "-d" so it will look for configs on /usr/local/fop2 directly (better this option if you upgrade FOP2 from the command line with wget).

    Best regards,
Sign In or Register to comment.