New install, on separate machine from asterisk

I have used fop2 before, but this is my first completely scratch install - I'm sure I am missing something...
I am trying to run a custom back end.
But I'm a little confused - I expected to need to define all my buttons manually however fop2 seems to have discovered them all already?

I used a local database on the webserver and pointed fop2 at the remote mangaer login.

Before I purchased a license, I installed, tested, confirmed connection, set up database, etc. and saw the warning that I had more than 15 buttons... For sure! I didn't SEE buttons, but presumed they were completely hidden. So I went and purchased. Now that I have installed the license, the admin panel seems to work fine (shows buttons, etc.). But when I log in to the user panel, I see only grey minimal info / no action buttons.
I have:

  • created a group with my coworkers extension
  • searched up my user extension and given it all permissions
  • added my group to my user (I have also tried all buttons, and leaving the groups empty)

I have restarted the service.

Intermittently I see the message "Panel Server is not responding. Be sure the service is running!"

But I am on the same LAN, the service is running. Not sure what that error might indicate?

Not sure what step I am missing - any advice appreciated.


Best Answers

  • Accepted Answer

    I feel stupid but not...
    After completely removing the:
    it still didn't work... so I started to debug...
    ./fop2_server --daemon --debuglevel 511 --logdir /var/log --audit /var/log/fop2_audit.log
    And suddenly it worked.
    So I restored the ;exec line, and it still works.
    It's been a long day - not sure what I did. But I am making progress now so happy.
    Hopefully someone can guess what I did.

  • Accepted Answer

    Hi Mitch,

    Hard to tell exactly after fiddling much with fop2 configuration files. If you are not using FreePBX/Issabel/Mirta, but a custom backend, then some special consideration is needed, and some clarifications on how the big scheme of things works in FOP2:

    1) Stock config files (and auto config scripts) rely on getting user/buttons configuration from the FOP2 Manager.
    2) FOP2 Manager needs to access a database to store its own data, and perhaps to retrieve backend data. If it recognizes a known installed backend, it will read mysql credentials for its config file and use those. If that connection fails, it will try to use the one defined in config.php (note you have two config.php, one for fop2 and one for fop2 manager in directory fop2/admin)
    3) If you can log into FOP2 Manager and add users, then MySQL access was successful
    4) If you remove/comment the #exec line in fop2.cfg, then nothing you do on FOP2 Manager will work, nor users you create or buttons you add via web will work. ever.
    5) Mixing manually created users in fop2.cfg and leaving the #exec line to mix results with FOP2 Manager will not work as expected. It might work sometimes, or not other times, depends on order of things, so, just don't do it.
    6) If no backend is detected, but credentials to access a specific database in fop2/admin/config.php are correct, and you have a tablesnamed sippeers or files like /etc/asterisk/sip.conf, it will attempt to read config from that source, using some static rules that might be fine, or not, depending on your setup,. You can modify functions-custom.php in FOP2 Manager to suit your needs in that case. In general, a sip.conf entry with callerid will be added as an extension, a sip.conf entry without callerid will be added as a trunk.
    7) If possible, try to use the FOP2 Manager and adapt functions-custom.php when using a custom backend to populate FOP2 internal configs, as uers/permissions and plugins can be still managed and you will limit the user errorness of a fully manual installation.

    I am sorry I cannot tell you what happened in your installation in this post, you can try to catch me on the live help and we can review your install together and see how it goes from there. But hopefully all of the above might shed some light to other users wanting to get FOP2 working with their custom setups.

    Best regards,


  • Continuing to work on my problem, I found that the auto-config scripts don't follow the fop2 admin config - they look for mysql config on their own through searchgin /etc/asterisk which I have been trying to remove. So I decided to try a manual config.
    I added a user, and a button. Now when I sign in the dialpad works, and I ahve action keys - so I suspect the auto scripts won't work for me (which is fine).

  • So I have changed to a manual config - inserted a ; in the from of the exec, and added:

    In buttons_custom.cfg I have:

    label=Mary Jones

    But when I log in with my new user and 1234 pin, I get no button.
    So I'm still a little stumped. Will keep poking after dinner if anyone has any ideas. Thanks

  • Just in case commenting the #exec with ; wasn't working, I removed that too.

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file