FOP2 not changing DND status

I am working on a new system that I migrated some stuff from old computer, so this is likely because of that process, but I would like to get some help/pointers on how to solve this.

On a side note, I didn't migrate any FOP2 files, FOP2 is a fresh install, but I did migrate the settings via FreePBX gui.

On the old working system, If i press *79 or *78 FOP2 shows that I have turned DND on/off. On the new phone systems, It took me a while to figure out FOP2 wasn't working when I hit available, and that I default to DND, I had to hit *79 and then I got calls inbound. (I was very happy at this moment!), but now I need to fix the issue of being able to hit DND/Available in FOP2 and have it correctly change that attribute in the phone systems so phones do or don't ring according to FOP2 status.

Any pointers to get me started?

1st thing I did was change FOP2 from running as user [admin] (I had 2 users [admin] with different permissions], FOP2 now runs under fop2 based on the following and has read/write = all permissions. Beyond that, not sure what I need to do, thanks in advance!
[root@node2 ~]# cat /usr/local/fop2/fop2.cfg
; AMI definitions

[root@node2 ~]# cat /etc/asterisk/manager.conf

secret = amp111
;deny =
;permit =
read = all
write = all
writetimeout = 1000
eventfilter=!Event: RTCP*
eventfilter=!Event: VarSet
eventfilter=!Event: Cdr
eventfilter=!Event: DTMF
eventfilter=!Event: AGIExec
eventfilter=!Event: ExtensionStatus
eventfilter=!Event: ChannelUpdate
eventfilter=!Event: ChallengeSent
eventfilter=!Event: SuccessfulAuth


  • You must create override macros for FreePBX to make DND and other feature codes signal FOP2:

    /usr/local/fop2/ -w

    Best regards,
  • I believe I already did that, but I will do it again, no harm right?

    Regardless, I think I fixed the issue, We use Device and User mode, and when I pulled over the Tarball with our settings, it didn't implement some of the functions. I went to Advanced Settings and changed it to Extensions mode, then back to Device and Users and hit apply, this seems to have resolved the problem, when I hit *79/*78 FOP2 changed its status. I still need to test with real outbound/inbound calling, but I can't ATM (We are open 4 business), but I think its fixed! If it is fixed, I will come back and mark as solved.

    Thanks for your quick reply.
  • Just wanted to link posts, but really, in another post I read, I found a good tip to check if its "working" which is
    root@node1:~ $ asterisk -rx "database show fop2state" | grep 847
    /fop2state/USER/847                               : Do not Disturb

    Here is my second post Re same thing, figured I'd like them..


    Install DND Presence Plugin in FOP2
  • And to check if its working, for FREEPBX check if the DND entry is set:

    asterisk -rx "database show DND" | grep 847

  • I am having some difficulty with this, although possibly because we are using FOP2 on a separate server. I did follow these instructions, also running the command
    /usr/local/fop2/ -w
    I can see the extensions change status to DND within the extension settings report in FreePBX.
    However, users are still able to make calls using the dialer or with click to call, which requires an incoming call, and we do not want that to work when presence is set to anything other than available. How can this be done?

Sign In or Register to comment.