Button Label not Updating

I have updated a label on the buttons page and reloaded the panel.
When I check the database the fop2buttons table is updated with the new name but the panel itself doesn't reflect it:
select * from fop2buttons where device = 'PJSIP/0132';
+------+------------+---------+-----------+-----------+------------+---------+---------------------------+-------+-------+-------+------------+---------+---------+--------------+------------------+-------------+------------+----------+-------------+------+----------------+--------------+--------+----------+--------------------+------------------------------------------------+--------------+--------------+
| id | context_id | exclude | sortorder | type | device | privacy | label | group | exten | email | context | mailbox | channel | queuechannel | originatechannel | customastdb | spyoptions | external | accountcode | tags | extenvoicemail | queuecontext | server | cssclass | originatevariables | autoanswerheader | sip_username | sip_password |
+------+------------+---------+-----------+-----------+------------+---------+---------------------------+-------+-------+-------+------------+---------+---------+--------------+------------------+-------------+------------+----------+-------------+------+----------------+--------------+--------+----------+--------------------+------------------------------------------------+--------------+--------------+
| 1661 | 0 | 0 | 369 | extension | PJSIP/0132 | NULL | Siphamandla Radebe <0132> | | 0132 | | extensions | 0132 | | | | CF/0132 | | | | | | | | | NULL | __SIPADDHEADER51=Call-Info: answer-after=0.001 | | |
+------+------------+---------+-----------+-----------+------------+---------+---------------------------+-------+-------+-------+------------+---------+---------+--------------+------------------+-------------+------------+----------+-------------+------+----------------+--------------+--------+----------+--------------------+------------------------------------------------+--------------+--------------+

Comments

  • Even more strange now. The name reflects correctly when the agent logs onto a queue on the queue panel but the extension button still has the old name.

  • I can confirm that with a server hard reset/reboot it resolves the button name.
    Can I ask for more information related to this problem and if an update is coming to resolve this?

  • I found an alternative way to update the label with our restarting the server.
    Sytemctl stop fop2
    Systemctl restart httpd
    Sytemctl start fop2

Sign In or Register to comment.