Browser deprecation of TLS v1.0 and v1.1 finally kicked in it seems. If you need to connect via https to FOP2, you must use version 2.31.28 (released more than one year and a half ago), that includes support for TLS v1.2
If your FOP2 license is older than a year, and your version is less that 2.31.28, in order to upgrade FOP2 to the latest version you will need to upgrade your license first. The annual software maintenance is $20, can be purchased from here:
https://www.fop2.com/buy.php?hint=annualupgrade
After upgrading the license, you can upgrade FOP2 to the latest version (2.31.31 at time of this post) with the command:
wget -O - http://download.fop2.com/upgrade_fop2.sh | bash
If you cannot or do not want to upgrade FOP2, then you will need to either install an older web browser, or use http instead of https that will work fine no matter the versions you have of browsers/fop2.