FOP2 2.30 Beta

  1. ‹ Older
  2. 3 years ago

    Hello, Just a suggestion :

    At the end of the upgrade, you should mention not only the config file of fop2 but the config file of fop2admin too.

    I must each time change the DB Access in both.

    Or for Elastix 3 MTE, you can use the default Elastix dB (elxpbx) and find the password of the db in /etc/elastix.conf
    you have a line :

    mysqlrootpwd=Password

    (user root for mysql)

    Thanks in advance

    Jean-Luc

  3. Hello, a small translation error to :
    In French, logout is "Deconnexion, not Deonnection

    Kindly

    Jean-Luc

  4. has FOP2 been tested at all or known to work with FreePBX 13 / asterisk 13 systems?

  5. admin

    16 Jan 2016 Administrator

    FOP2 2.30.x works well with Asterisk 13. Previous versions might have some little issues.

  6. 2 years ago

    @admin - This is a long shot, but we're running Asterisk (Ver. 11.19.0) with FreePBX 12.0.76.2 - Is it safe to install fop2 2.30 or will we see loads of issues?

    Thanks.

  7. admin

    10 Feb 2016 Administrator

    It is perfectly safe.

  8. Hello,
    How can I send commands by url?
    When fop2 extension installed typing fop2 allow you to type commands, like dial xxx.

    How can I do it with run commands from url?
    like http://192.168.1.10/fop2/dial xxx
    or
    http://192.168.1.10/fop2/?exten=100&pass=9999&context=tenantA&dial=xxx

    How can I use the fop2 api?

  9. admin

    24 Feb 2016 Administrator

    You cannot perform actions via URL. What you see when typing FOP2 are some smart actions available via the Chrome plugin only, where you can dial a number or change presence by typing it in the URL bar.

  10. So I can only strongly recommend that you will add/enable this option (even as a paid plugin)
    You already have great AMI proxy server that only asking for this option to be added.
    The only main commands needed are Originate a call and get CDR.
    Both are supported with a multi tenant and user authentication mechanism by your application.

  11. admin

    3 Mar 2016 Administrator

    It is not that simple. You want an http api, not a socket based one. Doing something like this:

    http://192.168.1.10/fop2/?exten=100&pass=9999&context=tenantA&dial=xxx

    Involves extra steps that are not needed. Accepting the http command/connection... then opening a websocket connection between browser and fop2 server (that takes time/cpu/etc), and then use the existing AMI connection on the proxy to perform a command.

    Much more simpler is to just use http with no websockets at all to get the command, and then forward it via AMI or similar interfaces. In fact, Asterisk 13 already has such API in place and its named ARI.

    I might write a different software using just http with no fop2 server needed in order to bridge AMI with the web, for older asterisk versions... but I think FOP2 is not the place to do it.

    If you want to use FOP2, you can just use the regular javascript protocol to do such things, if you enable debug on the fop2 server to level 12 you will clearly see the 'dialog' between the browser and the server, you can write your custom clients following that protocol if you want.

    Best regards,

  12. Hello,

    Just upgraded to the new fop server via the management GUI.
    Can't login any more.
    fop2 log show all logins as FAILED LOGIN (non existant user).
    /autoconfig-users.sh show correct users and passwords but using same credentials fail.

    Any idea?

  13. admin

    14 Mar 2016 Administrator

    If you use the users listed in the output from autoconfig-users.sh and it does not work, either your fop2.cfg is not using that script as a base for configuration or has some other conflicting config entries, or perhaps FOP2 just needs to be reloaded.

    Best regards,

  14. It using that script (it's exactly as it was before the upgrade).
    Notice something else, when pressing submit changes and not pressing the reload I can login but see no buttons.
    When press the reload after the submit changes I can't login.

    As stated before, the fop server was upgraded from the management GUI alone.
    Verify all configuration files and they as they were before.

  15. admin

    14 Mar 2016 Administrator

    You upgraded only the FOP2 Manager, not the fop2 server. Anyways, a manager upgrade should not leave you with no service. Please try restarting the fop2 service from the command line.. did you try that?

    service fop2 restart

    Best regards,

  16. First thing I've done.
    There's no one online to take a look?

  17. It's a production server so all users can't access the FOP.
    Don't know what cause this but every upgrade I have some issues and/or changes need to be done in a code related to the upgrade.

  18. admin

    14 Mar 2016 Administrator

    Are you using custom function for the manager due to multi tenant? You should avoid upgrading if that is the case. I am online if you want to chat.

  19. admin

    14 Mar 2016 Administrator

    I am online at the live help now.

  20. Solved in a flash by Nicolas.
    I'm sure he can give a few words for other future users with same symptoms.

  21. admin

    14 Mar 2016 Administrator
    Edited 2 years ago by admin

    Ok.. problem was due to the usage of a multi tenant system with FOP2 version 2.30.00 (old). The latest FOP2 Manager allows the selection of individual tenants to enable the service, so you can select which tenants will have access to the FOP2 service. That way you can use the standard license with no extra costs to give service for up to 5 tenants. sbasan had much more than 5 tenants, but not an extended license, and the Tenant selection in the newer FOP2 Manager works only with the updated autoconfiguration scripts in more recent FOP2 versions. By using an older FOP2 version, the previous autoconfiguration scripts just printed out all tenants, not only the selected ones from the FOP2 Manager, and reached the 5 tenant limit making some tenants unavailable.

    So, if you use an older FOP2 with a multi tenant system and plan to use the tenant selection via the FOP2 Manager, then go ahead and upgrade everything: fop2 and the fop2 manager. If you upgrade only the fop2 manager you have the change of having features that won't work with the server, like this tenant selection.

    In this particular case, updating just autoconfig-users.sh in his installation with the latest version fixed the issue.

or Sign Up to reply!